Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Interactive Connectivity Establishment library" |
| 2 | DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)." |
| 3 | HOMEPAGE = "http://nice.freedesktop.org/wiki/" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | LICENSE = "LGPL-2.1-only & MPL-1.1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \ |
| 7 | file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 8 | file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \ |
| 9 | " |
| 10 | |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 11 | SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "5eabd25ba2b54e817699832826269241abaa1cf78f9b240d1435f936569273f4" |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 13 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | DEPENDS = "glib-2.0 gnutls" |
| 15 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 16 | PACKAGECONFIG[gupnp] = "-Dgupnp=enabled,-Dgupnp=disabled,gupnp" |
| 17 | PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0" |
| 18 | PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled," |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 20 | EXTRA_OEMESON = "-Dgstreamer=disabled" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 22 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 23 | GTKDOC_MESON_ENABLE_FLAG = "enabled" |
| 24 | GTKDOC_MESON_DISABLE_FLAG = "disabled" |
| 25 | |
| 26 | inherit meson gtk-doc gobject-introspection |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | FILES:${PN} += "${libdir}/gstreamer-1.0/*.so" |
| 29 | FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.la" |
| 30 | FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" |
| 31 | FILES:${PN}-dbg += "${libdir}/gstreamer-1.0/.debug" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | do_configure:prepend() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 34 | mkdir ${S}/m4 || true |
| 35 | } |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | do_compile:append() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | for i in $(find ${B} -name "*.pc") ; do |
| 39 | sed -i -e s:${STAGING_DIR_TARGET}::g \ |
| 40 | -e s:/${TARGET_SYS}::g \ |
| 41 | $i |
| 42 | done |
| 43 | } |