blob: 74e7074a5397b6c2b017c9833ded4ff369fc80c1 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Some of the vars for vm and live image are conflicted, this function
2# is used for fixing the problem.
3def set_live_vm_vars(d, suffix):
4 vars = ['GRUB_CFG', 'SYSLINUX_CFG', 'ROOT', 'LABELS', 'INITRD']
5 for var in vars:
6 var_with_suffix = var + '_' + suffix
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007 if d.getVar(var):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05008 bb.warn('Found potential conflicted var %s, please use %s rather than %s' % \
9 (var, var_with_suffix, var))
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 elif d.getVar(var_with_suffix):
11 d.setVar(var, d.getVar(var_with_suffix))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012
13
14EFI = "${@bb.utils.contains("MACHINE_FEATURES", "efi", "1", "0", d)}"
15EFI_PROVIDER ?= "grub-efi"
16EFI_CLASS = "${@bb.utils.contains("MACHINE_FEATURES", "efi", "${EFI_PROVIDER}", "", d)}"
17
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018MKDOSFS_EXTRAOPTS ??= "-S 512"
19
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050020# Include legacy boot if MACHINE_FEATURES includes "pcbios" or if it does not
21# contain "efi". This way legacy is supported by default if neither is
22# specified, maintaining the original behavior.
23def pcbios(d):
24 pcbios = bb.utils.contains("MACHINE_FEATURES", "pcbios", "1", "0", d)
25 if pcbios == "0":
26 pcbios = bb.utils.contains("MACHINE_FEATURES", "efi", "0", "1", d)
27 return pcbios
28
29PCBIOS = "${@pcbios(d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030PCBIOS_CLASS = "${@['','syslinux'][d.getVar('PCBIOS') == '1']}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050031
Brad Bishopa34c0302019-09-23 22:34:48 -040032# efi_populate_common DEST BOOTLOADER
33efi_populate_common() {
34 # DEST must be the root of the image so that EFIDIR is not
35 # nested under a top level directory.
36 DEST=$1
37
38 install -d ${DEST}${EFIDIR}
39
40 install -m 0644 ${DEPLOY_DIR_IMAGE}/$2-${EFI_BOOT_IMAGE} ${DEST}${EFIDIR}/${EFI_BOOT_IMAGE}
41 EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g')
42 printf 'fs0:%s\%s\n' "$EFIPATH" "${EFI_BOOT_IMAGE}" >${DEST}/startup.nsh
43}
44
45efi_iso_populate() {
46 iso_dir=$1
47 efi_populate $iso_dir
48 # Build a EFI directory to create efi.img
49 mkdir -p ${EFIIMGDIR}/${EFIDIR}
50 cp $iso_dir/${EFIDIR}/* ${EFIIMGDIR}${EFIDIR}
51 cp $iso_dir/${KERNEL_IMAGETYPE} ${EFIIMGDIR}
52
53 EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g')
54 printf 'fs0:%s\%s\n' "$EFIPATH" "${EFI_BOOT_IMAGE}" >${EFIIMGDIR}/startup.nsh
55
56 if [ -f "$iso_dir/initrd" ] ; then
57 cp $iso_dir/initrd ${EFIIMGDIR}
58 fi
59}
60
61efi_hddimg_populate() {
62 efi_populate $1
63}
64
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050065inherit ${EFI_CLASS}
66inherit ${PCBIOS_CLASS}
67
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050068populate_kernel() {
69 dest=$1
70 install -d $dest
71
72 # Install bzImage, initrd, and rootfs.img in DEST for all loaders to use.
Brad Bishop316dfdd2018-06-25 12:45:53 -040073 bbnote "Trying to install ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} as $dest/${KERNEL_IMAGETYPE}"
74 if [ -e ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} ]; then
75 install -m 0644 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} $dest/${KERNEL_IMAGETYPE}
Patrick Williamsc0f7c042017-02-23 20:41:17 -060076 else
Brad Bishop316dfdd2018-06-25 12:45:53 -040077 bbwarn "${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE} doesn't exist"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050078 fi
79
80 # initrd is made of concatenation of multiple filesystem images
81 if [ -n "${INITRD}" ]; then
82 rm -f $dest/initrd
83 for fs in ${INITRD}
84 do
85 if [ -s "$fs" ]; then
86 cat $fs >> $dest/initrd
87 else
88 bbfatal "$fs is invalid. initrd image creation failed."
89 fi
90 done
91 chmod 0644 $dest/initrd
92 fi
93}
94