blob: 46cc26e67ed9f4038c9c2b00cee3ae2cd2281d60 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
Patrick Williams03907ee2022-05-01 06:28:52 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=72c536e78c21c567311b193fe00cd253"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006
7PYPI_PACKAGE = "Sphinx"
8
Andrew Geissler615f2f12022-07-15 14:00:58 -05009SRC_URI[sha256sum] = "b18e978ea7565720f26019c702cd85c84376e948370f1cd43d60265010e1c7b0"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
11inherit setuptools3 pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-packaging python3-docutils python3-requests \
21 python3-imagesize python3-alabaster python3-jinja2 \
22 python3-babel python3-pygments python3-snowballstemmer \
23 python3-sphinxcontrib-applehelp python3-sphinxcontrib-devhelp \
24 python3-sphinxcontrib-jsmath python3-sphinxcontrib-htmlhelp \
25 python3-sphinxcontrib-serializinghtml python3-sphinxcontrib-qthelp \
26 "
27
28BBCLASSEXTEND = "native nativesdk"