blob: ea29b668e895b59d1e2908cbc246c314ebf5d91b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "U-Boot libraries and tools to access environment"
Andrew Geissler82c905d2020-04-13 13:39:40 -05002
3DESCRIPTION = "This package contains tools and libraries to read \
4and modify U-Boot environment. \
5It provides a hardware-independent replacement for fw_printenv/setenv utilities \
6provided by U-Boot"
7
8HOMEPAGE = "https://github.com/sbabic/libubootenv"
9LICENSE = "LGPL-2.1"
10LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "libs"
12
13PV = "0.2+git${SRCPV}"
14SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
15SRCREV = "f4b9cde3815abe84a98079cedd515283ea08c16b"
16
17S = "${WORKDIR}/git"
18
19inherit cmake lib_package
20
21EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
22
Andrew Geissler4ed12e12020-06-05 18:00:41 -050023DEPENDS = "zlib"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024PROVIDES += "u-boot-fw-utils"
25RPROVIDES_${PN}-bin += "u-boot-fw-utils"
26
27BBCLASSEXTEND = "native"