blob: d964de5bf6b613987381df5e1717fcaceada2542 [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001DESCRIPTION = "Commented config.txt file for the Raspberry Pi. \
2 The Raspberry Pi config.txt file is read by the GPU before \
3 the ARM core is initialised. It can be used to set various \
4 system configuration parameters."
5LICENSE = "MIT"
Brad Bishopf27bdd52018-05-07 15:42:31 +02006LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
Patrick Williams8b8bc412016-08-17 15:02:23 -05007
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008COMPATIBLE_MACHINE = "^rpi$"
Patrick Williams8b8bc412016-08-17 15:02:23 -05009
10SRCREV = "648ffc470824c43eb0d16c485f4c24816b32cd6f"
11SRC_URI = "git://github.com/Evilpaul/RPi-config.git;protocol=git;branch=master \
12 "
13
14S = "${WORKDIR}/git"
15
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060016PR = "r5"
Patrick Williams8b8bc412016-08-17 15:02:23 -050017
Brad Bishop316dfdd2018-06-25 12:45:53 -040018INHIBIT_DEFAULT_DEPS = "1"
19
Patrick Williams8b8bc412016-08-17 15:02:23 -050020PITFT="${@bb.utils.contains("MACHINE_FEATURES", "pitft", "1", "0", d)}"
21PITFT22="${@bb.utils.contains("MACHINE_FEATURES", "pitft22", "1", "0", d)}"
22PITFT28r="${@bb.utils.contains("MACHINE_FEATURES", "pitft28r", "1", "0", d)}"
Brad Bishop1b9ee292020-01-16 09:06:00 -050023PITFT28c="${@bb.utils.contains("MACHINE_FEATURES", "pitft28c", "1", "0", d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024PITFT35r="${@bb.utils.contains("MACHINE_FEATURES", "pitft35r", "1", "0", d)}"
Patrick Williams8b8bc412016-08-17 15:02:23 -050025
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060026VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027VC4DTBO ?= "vc4-kms-v3d"
Andrew Geissler4fc9e432020-06-27 00:13:56 -050028GPIO_IR ?= "18"
29GPIO_IR_TX ?= "17"
Brad Bishop316dfdd2018-06-25 12:45:53 -040030
31inherit deploy nopackages
Patrick Williams8b8bc412016-08-17 15:02:23 -050032
33do_deploy() {
34 install -d ${DEPLOYDIR}/bcm2835-bootfiles
35
36 cp ${S}/config.txt ${DEPLOYDIR}/bcm2835-bootfiles/
37
38 if [ -n "${KEY_DECODE_MPG2}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040039 sed -i '/#decode_MPG2=/ c\decode_MPG2=${KEY_DECODE_MPG2}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050040 fi
41 if [ -n "${KEY_DECODE_WVC1}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040042 sed -i '/#decode_WVC1=/ c\decode_WVC1=${KEY_DECODE_WVC1}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050043 fi
44 if [ -n "${DISABLE_OVERSCAN}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040045 sed -i '/#disable_overscan=/ c\disable_overscan=${DISABLE_OVERSCAN}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050046 fi
Brad Bishop26bdd442019-08-16 17:08:17 -040047 if [ "${DISABLE_SPLASH}" = "1" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040048 sed -i '/#disable_splash=/ c\disable_splash=${DISABLE_SPLASH}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
49 fi
50
51 # Set overclocking options
Patrick Williams8b8bc412016-08-17 15:02:23 -050052 if [ -n "${ARM_FREQ}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040053 sed -i '/#arm_freq=/ c\arm_freq=${ARM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
54 fi
55 if [ -n "${GPU_FREQ}" ]; then
56 sed -i '/#gpu_freq=/ c\gpu_freq=${GPU_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050057 fi
58 if [ -n "${CORE_FREQ}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040059 sed -i '/#core_freq=/ c\core_freq=${CORE_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050060 fi
61 if [ -n "${SDRAM_FREQ}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040062 sed -i '/#sdram_freq=/ c\sdram_freq=${SDRAM_FREQ}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050063 fi
64 if [ -n "${OVER_VOLTAGE}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040065 sed -i '/#over_voltage=/ c\over_voltage=${OVER_VOLTAGE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050066 fi
67
68 # GPU memory
69 if [ -n "${GPU_MEM}" ]; then
70 sed -i '/#gpu_mem=/ c\gpu_mem=${GPU_MEM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
71 fi
72 if [ -n "${GPU_MEM_256}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040073 sed -i '/#gpu_mem_256=/ c\gpu_mem_256=${GPU_MEM_256}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050074 fi
75 if [ -n "${GPU_MEM_512}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040076 sed -i '/#gpu_mem_512=/ c\gpu_mem_512=${GPU_MEM_512}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -050077 fi
78 if [ -n "${GPU_MEM_1024}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -040079 sed -i '/#gpu_mem_1024=/ c\gpu_mem_1024=${GPU_MEM_1024}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
80 fi
81
82 # Set boot delay
83 if [ -n "${BOOT_DELAY}" ]; then
84 sed -i '/#boot_delay=/ c\boot_delay=${BOOT_DELAY}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
85 fi
86 if [ -n "${BOOT_DELAY_MS}" ]; then
87 sed -i '/#boot_delay_ms=/ c\boot_delay_ms=${BOOT_DELAY_MS}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
88 fi
89
90 # Set HDMI and composite video options
91 if [ -n "${HDMI_FORCE_HOTPLUG}" ]; then
92 sed -i '/#hdmi_force_hotplug=/ c\hdmi_force_hotplug=${HDMI_FORCE_HOTPLUG}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
93 fi
94 if [ -n "${HDMI_DRIVE}" ]; then
95 sed -i '/#hdmi_drive=/ c\hdmi_drive=${HDMI_DRIVE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
96 fi
97 if [ -n "${HDMI_GROUP}" ]; then
98 sed -i '/#hdmi_group=/ c\hdmi_group=${HDMI_GROUP}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
99 fi
100 if [ -n "${HDMI_MODE}" ]; then
101 sed -i '/#hdmi_mode=/ c\hdmi_mode=${HDMI_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
102 fi
103 if [ -n "${CONFIG_HDMI_BOOST}" ]; then
104 sed -i '/#config_hdmi_boost=/ c\config_hdmi_boost=${CONFIG_HDMI_BOOST}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
105 fi
106 if [ -n "${SDTV_MODE}" ]; then
107 sed -i '/#sdtv_mode=/ c\sdtv_mode=${SDTV_MODE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
108 fi
109 if [ -n "${SDTV_ASPECT}" ]; then
110 sed -i '/#sdtv_aspect=/ c\sdtv_aspect=${SDTV_ASPECT}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
111 fi
112 if [ -n "${DISPLAY_ROTATE}" ]; then
113 sed -i '/#display_rotate=/ c\display_rotate=${DISPLAY_ROTATE}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williams8b8bc412016-08-17 15:02:23 -0500114 fi
115
116 # Video camera support
Brad Bishop26bdd442019-08-16 17:08:17 -0400117 if [ "${VIDEO_CAMERA}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500118 echo "# Enable video camera" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
119 echo "start_x=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
120 fi
121
122 # Offline compositing support
Brad Bishop26bdd442019-08-16 17:08:17 -0400123 if [ "${DISPMANX_OFFLINE}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500124 echo "# Enable offline compositing" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
125 echo "dispmanx_offline=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
126 fi
127
128 # SPI bus support
Brad Bishop26bdd442019-08-16 17:08:17 -0400129 if [ "${ENABLE_SPI_BUS}" = "1" ] || [ "${PITFT}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500130 echo "# Enable SPI bus" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
131 echo "dtparam=spi=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
132 fi
133
Brad Bishop316dfdd2018-06-25 12:45:53 -0400134 # I2C support
Brad Bishop26bdd442019-08-16 17:08:17 -0400135 if [ "${ENABLE_I2C}" = "1" ] || [ "${PITFT}" = "1" ]; then
Patrick Williams8b8bc412016-08-17 15:02:23 -0500136 echo "# Enable I2C" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
137 echo "dtparam=i2c1=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
138 echo "dtparam=i2c_arm=on" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
139 fi
140
141 # PiTFT22 display support
142 if [ "${PITFT22}" = "1" ]; then
143 echo "# Enable PITFT22 display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
144 echo "dtoverlay=pitft22,rotate=270,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
145 fi
Patrick Williams8b8bc412016-08-17 15:02:23 -0500146 if [ "${PITFT28r}" = "1" ]; then
147 echo "# Enable PITFT28r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
148 echo "dtoverlay=pitft28-resistive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
149 fi
Brad Bishop1b9ee292020-01-16 09:06:00 -0500150 if [ "${PITFT28c}" = "1" ]; then
151 echo "# Enable PITFT28c display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
152 echo "dtoverlay=pitft28-capacitive,rotate=90,speed=32000000,txbuflen=32768" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
153 echo "dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
154 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500155 if [ "${PITFT35r}" = "1" ]; then
156 echo "# Enable PITFT35r display" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
157 echo "dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
158 fi
159
Patrick Williams8b8bc412016-08-17 15:02:23 -0500160 # UART support
161 if [ "${ENABLE_UART}" = "1" ]; then
162 echo "# Enable UART" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
163 echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
164 fi
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -0600165
Andrew Geissler4fc9e432020-06-27 00:13:56 -0500166 # Infrared support
167 if [ "${ENABLE_IR}" = "1" ]; then
168 echo "# Enable infrared" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
169 echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
170 echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
171 fi
172
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -0600173 # VC4 Graphics support
174 if [ "${VC4GRAPHICS}" = "1" ]; then
175 echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800176 echo "dtoverlay=${VC4DTBO}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -0600177 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500178
179 # Waveshare "C" 1024x600 7" Rev2.1 IPS capacitive touch (http://www.waveshare.com/7inch-HDMI-LCD-C.htm)
180 if [ "${WAVESHARE_1024X600_C_2_1}" = "1" ]; then
181 echo "# Waveshare \"C\" 1024x600 7\" Rev2.1 IPS capacitive touch screen" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
182 echo "max_usb_current=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
183 echo "hdmi_group=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
184 echo "hdmi_mode=87" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
185 echo "hdmi_cvt 1024 600 60 6 0 0 0" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
186 echo "hdmi_drive=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
187 fi
Brad Bishop316dfdd2018-06-25 12:45:53 -0400188
189 # DWC2 USB peripheral support
190 if [ "${ENABLE_DWC2_PERIPHERAL}" = "1" ]; then
191 echo "# Enable USB peripheral mode" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
192 echo "dtoverlay=dwc2,dr_mode=peripheral" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
193 fi
Brad Bishopf27bdd52018-05-07 15:42:31 +0200194
195 # AT86RF23X support
196 if [ "${ENABLE_AT86RF}" = "1" ]; then
197 echo "# Enable AT86RF23X" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
198 echo "dtoverlay=at86rf233,speed=3000000" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
199 fi
200
Brad Bishop19323692019-04-05 15:28:33 -0400201 # ENABLE CAN
202 if [ "${ENABLE_CAN}" = "1" ]; then
203 echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
204 echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
205 fi
206
Brad Bishop316dfdd2018-06-25 12:45:53 -0400207 # Append extra config if the user has provided any
Andrew Geissler1c349142019-02-19 19:49:56 -0600208 printf "${RPI_EXTRA_CONFIG}\n" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Brad Bishop26bdd442019-08-16 17:08:17 -0400209
210 # Handle setup with armstub file
211 if [ "${@bb.utils.contains("MACHINE_FEATURES", "armstub", "1", "0", d)}" = "1" ]; then
212 echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
213 echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
214 case "${ARMSTUB}" in
215 *-gic.bin)
216 echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
217 ;;
218 esac
219 fi
Patrick Williams8b8bc412016-08-17 15:02:23 -0500220}
221
Brad Bishop3a5fbf52017-12-04 02:17:07 -0500222do_deploy_append_raspberrypi3-64() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500223 echo "# have a properly sized image" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
224 echo "disable_overscan=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
225
226 echo "# Enable audio (loads snd_bcm2835)" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
227 echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
Brad Bishop3a5fbf52017-12-04 02:17:07 -0500228}
229
Brad Bishop316dfdd2018-06-25 12:45:53 -0400230addtask deploy before do_build after do_install
Patrick Williams8b8bc412016-08-17 15:02:23 -0500231do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
232
233PACKAGE_ARCH = "${MACHINE_ARCH}"