blob: 35f9bb2516068680004efad6924d4bc8d974b3fb [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.bitbucket.org/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=07384b3aa2e0d39afca0d6c40286f545"
13
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
16SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017 file://0001-annotate.c-gdft.c-Replace-strncpy-with-memccpy-to-fi.patch \
18 file://CVE-2018-1000222.patch \
Brad Bishop4fe7a132019-10-07 09:34:48 -040019 file://CVE-2019-6978.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040020 "
21
22SRCREV = "8255231b68889597d04d451a72438ab92a405aba"
23
24S = "${WORKDIR}/git"
25
26inherit autotools binconfig gettext pkgconfig
27
28EXTRA_OECONF += " --disable-rpath \
29 --with-jpeg=${STAGING_LIBDIR}/.. \
30 --with-freetype=yes \
31 --without-fontconfig \
32 --without-webp \
33 --without-xpm \
34 --without-x \
35 "
36
37EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
38
Brad Bishopc342db32019-05-15 21:57:59 -040039DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"
40
Brad Bishop316dfdd2018-06-25 12:45:53 -040041do_install_append() {
42 # cleanup buildpaths from gdlib.pc
43 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
44}
45
46PACKAGES += "${PN}-tools"
47
48FILES_${PN} = "${libdir}/lib*${SOLIBS}"
49FILES_${PN}-tools = "${bindir}/*"
50
51PROVIDES += "${PN}-tools"
52RPROVIDES_${PN}-tools = "${PN}-tools"
53RDEPENDS_${PN}-tools = "perl perl-module-strict"
Brad Bishopc342db32019-05-15 21:57:59 -040054
55CVE_PRODUCT = "libgd"