blob: 4dbd418b60d973fdc9b1947ac532755d83817cd7 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-3.0-only"
Andrew Geissler5082cc72023-09-11 08:41:39 -04007LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
Brad Bishopc342db32019-05-15 21:57:59 -04008
Andrew Geissler5082cc72023-09-11 08:41:39 -04009SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2"
Brad Bishopc342db32019-05-15 21:57:59 -040010
Andrew Geissler5082cc72023-09-11 08:41:39 -040011SRC_URI[sha256sum] = "7edb8886a3dc69420a1446e1e2d061922b642f1cf632d2cd0f9ee7e690775985"
Brad Bishopc342db32019-05-15 21:57:59 -040012
13inherit autotools gettext texinfo
14
15PACKAGECONFIG ??= ""
Patrick Williams213cb262021-08-07 19:21:33 -050016PACKAGECONFIG:append:class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
Brad Bishopc342db32019-05-15 21:57:59 -040017
18PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
Andrew Geissler5199d832021-09-24 16:47:35 -050019PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
Brad Bishopc342db32019-05-15 21:57:59 -040020
21EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no"
24
Brad Bishopc342db32019-05-15 21:57:59 -040025# Let aclocal use the relative path for the m4 file rather than the
26# absolute since tar has a lot of m4 files, otherwise there might
27# be an "Argument list too long" error when it is built in a long/deep
28# directory.
29acpaths = "-I ./m4"
30
31do_install () {
32 autotools_do_install
33 ln -s tar ${D}${bindir}/gtar
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036do_install:append:class-target() {
Brad Bishopc342db32019-05-15 21:57:59 -040037 if [ "${base_bindir}" != "${bindir}" ]; then
38 install -d ${D}${base_bindir}
39 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
40 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
41 rmdir ${D}${bindir}/
42 fi
43}
44
45PACKAGES =+ "${PN}-rmt"
46
Patrick Williams213cb262021-08-07 19:21:33 -050047FILES:${PN}-rmt = "${sbindir}/rmt*"
Brad Bishopc342db32019-05-15 21:57:59 -040048
49inherit update-alternatives
50
51ALTERNATIVE_PRIORITY = "100"
52
Patrick Williams213cb262021-08-07 19:21:33 -050053ALTERNATIVE:${PN} = "tar"
54ALTERNATIVE:${PN}-rmt = "rmt"
55ALTERNATIVE:${PN}:class-nativesdk = ""
56ALTERNATIVE:${PN}-rmt:class-nativesdk = ""
Brad Bishopc342db32019-05-15 21:57:59 -040057
58ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
59ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
60
Patrick Williams213cb262021-08-07 19:21:33 -050061PROVIDES:append:class-native = " tar-replacement-native"
Brad Bishopc342db32019-05-15 21:57:59 -040062NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
63
64BBCLASSEXTEND = "native nativesdk"
Patrick Williams0ca19cc2021-08-16 14:03:13 -050065
Andrew Geisslereff27472021-10-29 15:35:00 -050066# Avoid false positives from CVEs in node-tar package
67# For example CVE-2021-{32803,32804,37701,37712,37713}
68CVE_PRODUCT = "gnu:tar"