blob: b0958e697577c07bf79534347ab0fc7336328c5a [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "A suite for man in the middle attacks"
2HOMEPAGE = "https://github.com/Ettercap/ettercap"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-or-later"
Andrew Geisslerd688a012020-09-18 13:36:00 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6inherit cmake
7
8DEPENDS += "ethtool \
9 geoip \
10 librepo \
11 libnet \
12 libpcap \
Andrew Geissler517393d2023-01-13 08:55:19 -060013 libpcre \
Andrew Geisslerd688a012020-09-18 13:36:00 -050014 ncurses \
15 openssl \
16 zlib \
17 bison-native \
18 flex-native \
19 "
20
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN} += "bash ethtool libgcc"
Andrew Geisslerd688a012020-09-18 13:36:00 -050022
Andrew Geissler595f6302022-01-24 19:11:47 +000023SRC_URI = "gitsm://github.com/Ettercap/ettercap;branch=master;protocol=https"
Andrew Geisslerd688a012020-09-18 13:36:00 -050024
25SRCREV = "7281fbddb7da7478beb1d21e3cb105fff3778b31"
26
27S = "${WORKDIR}/git"
28
29EXTRA_OECMAKE = " \
30 -DCMAKE_SKIP_RPATH=TRUE \
31 -DBUNDLED_LIBS=ON \
32 -DENABLE_IPV6=ON \
33 -DENABLE_GTK=OFF \
34"
35
Andrew Geissler87f5cff2022-09-30 13:13:31 -050036CFLAGS += "-D_GNU_SOURCE"
Andrew Geisslerd688a012020-09-18 13:36:00 -050037# Replaces default encoding set (ISO-8859-1) with UTF-8 in ettercap
38# configuration file installed by the package.
39# It ensures that all characters are properly decoded and avoids
40# any fatal errors while running in text mode (-T).
Patrick Williams213cb262021-08-07 19:21:33 -050041do_install:append() {
Andrew Geisslerd688a012020-09-18 13:36:00 -050042 sed -i 's@utf8_encoding.*@utf8_encoding = "UTF-8"@g' \
43 ${D}/etc/ettercap/etter.conf
44}