blob: 6e93ec9b0c1905bcfe630788b2b4df73ed5d4bcc [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "mongodb"
2LICENSE = "SSPL-1 & Apache-2.0 & Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \
4 file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS = "openssl libpcap zlib boost curl python3 \
7 python3-setuptools-native \
8 python3-pyyaml-native python3-cheetah-native \
9 python3-psutil-native python3-regex-native \
10 "
11
Andrew Geisslerd688a012020-09-18 13:36:00 -050012inherit scons dos2unix siteinfo python3native systemd useradd
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
Patrick Williams03907ee2022-05-01 06:28:52 -050014PV = "4.4.13"
15#v4.4.13
16SRCREV = "df25c71b8674a78e17468f48bcda5285decb9246"
Andrew Geissler595f6302022-01-24 19:11:47 +000017SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4;protocol=https \
Andrew Geissler82c905d2020-04-13 13:39:40 -050018 file://0001-Tell-scons-to-use-build-settings-from-environment-va.patch \
19 file://0001-Use-long-long-instead-of-int64_t.patch \
20 file://0001-Use-__GLIBC__-to-control-use-of-gnu_get_libc_version.patch \
21 file://0002-Add-a-definition-for-the-macro-__ELF_NATIVE_CLASS.patch \
22 file://arm64-support.patch \
23 file://0001-IntelRDFPMathLib20U1-Check-for-__DEFINED_wchar_t.patch \
24 file://0001-Support-deprecated-resolver-functions.patch \
25 file://0003-Fix-unknown-prefix-env.patch \
26 file://1296.patch \
Andrew Geisslerd688a012020-09-18 13:36:00 -050027 file://0001-Fix-compilation-with-fno-common.patch \
28 file://0001-stacktrace-Define-ARCH_BITS-for-x86.patch \
Andrew Geissler97771a32021-03-05 15:23:11 -060029 file://0001-include-needed-c-header.patch \
Andrew Geissler32b11992021-03-31 13:37:05 -050030 file://disable_runtime_check.patch \
31 file://ppc64_ARCH_BITS.patch \
Patrick Williams213cb262021-08-07 19:21:33 -050032 file://PTHREAD_STACK_MIN.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050033 file://0001-add-explict-static_cast-size_t-to-maxMemoryUsageByte.patch \
34 file://0001-server-Adjust-the-cache-alignment-assumptions.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050035 file://0001-The-std-lib-unary-binary_function-base-classes-are-d.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 "
Patrick Williams213cb262021-08-07 19:21:33 -050037SRC_URI:append:libc-musl ="\
Andrew Geissler82c905d2020-04-13 13:39:40 -050038 file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \
39 file://0002-Fix-default-stack-size-to-256K.patch \
40 file://0004-wiredtiger-Disable-strtouq-on-musl.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060041 file://0001-wiredtiger-Avoid-using-off64_t.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050042 "
43
Patrick Williams213cb262021-08-07 19:21:33 -050044SRC_URI:append:toolchain-clang = "\
Andrew Geissler82c905d2020-04-13 13:39:40 -050045 file://0001-asio-Dont-use-experimental-with-clang.patch \
46 "
47
48S = "${WORKDIR}/git"
49
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050050CVE_CHECK_IGNORE += "\
51 CVE-2014-8180 \
52 CVE-2017-18381 \
53 CVE-2017-2665 \
54"
55
Andrew Geissler82c905d2020-04-13 13:39:40 -050056COMPATIBLE_HOST ?= '(x86_64|i.86|powerpc64|arm|aarch64).*-linux'
57
58PACKAGECONFIG ??= "tcmalloc system-pcre"
59# gperftools compilation fails for arm below v7 because of missing support of
60# dmb operation. So we use system-allocator instead of tcmalloc
Patrick Williams213cb262021-08-07 19:21:33 -050061PACKAGECONFIG:remove:armv6 = "tcmalloc"
62PACKAGECONFIG:remove:libc-musl = "tcmalloc"
63PACKAGECONFIG:remove:riscv64 = "tcmalloc"
64PACKAGECONFIG:remove:riscv32 = "tcmalloc"
Andrew Geissler82c905d2020-04-13 13:39:40 -050065
66PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools,"
67PACKAGECONFIG[shell] = ",--js-engine=none,,"
68PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre,"
69
Andrew Geissler32b11992021-03-31 13:37:05 -050070MONGO_ARCH ?= "${HOST_ARCH}"
Patrick Williams213cb262021-08-07 19:21:33 -050071MONGO_ARCH:powerpc64le = "ppc64le"
Andrew Geissler69721092021-07-23 12:57:00 -040072WIREDTIGER ?= "off"
Patrick Williams213cb262021-08-07 19:21:33 -050073WIREDTIGER:x86-64 = "on"
74WIREDTIGER:aarch64 = "on"
Andrew Geissler32b11992021-03-31 13:37:05 -050075
Andrew Geisslerd688a012020-09-18 13:36:00 -050076EXTRA_OESCONS = "PREFIX=${prefix} \
77 DESTDIR=${D} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050078 LIBPATH=${STAGING_LIBDIR} \
79 LINKFLAGS='${LDFLAGS}' \
80 CXXFLAGS='${CXXFLAGS}' \
Andrew Geissler32b11992021-03-31 13:37:05 -050081 TARGET_ARCH=${MONGO_ARCH} \
Andrew Geisslerd688a012020-09-18 13:36:00 -050082 MONGO_VERSION=${PV} \
83 OBJCOPY=${OBJCOPY} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050084 --ssl \
85 --disable-warnings-as-errors \
86 --use-system-zlib \
87 --nostrip \
88 --endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
Andrew Geissler69721092021-07-23 12:57:00 -040089 --wiredtiger='${WIREDTIGER}' \
Andrew Geisslerd688a012020-09-18 13:36:00 -050090 --separate-debug \
91 ${PACKAGECONFIG_CONFARGS}"
92
Andrew Geisslerd688a012020-09-18 13:36:00 -050093USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050094USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/${BPN} --shell /bin/false --user-group ${BPN}"
Andrew Geisslerd688a012020-09-18 13:36:00 -050095
Andrew Geissler82c905d2020-04-13 13:39:40 -050096scons_do_compile() {
Andrew Geissler595f6302022-01-24 19:11:47 +000097 ${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} ${EXTRA_OESCONS} install-core ||
Andrew Geissler82c905d2020-04-13 13:39:40 -050098 die "scons build execution failed."
99}
100
101scons_do_install() {
Andrew Geissler595f6302022-01-24 19:11:47 +0000102 # install binaries
103 install -d ${D}${bindir}
104 for i in mongod mongos mongo; do
105 if [ -f ${B}/build/opt/mongo/$i ]; then
106 install -m 0755 ${B}/build/opt/mongo/$i ${D}${bindir}
107 else
108 bbnote "$i does not exist"
109 fi
110 done
Andrew Geisslerd688a012020-09-18 13:36:00 -0500111
Andrew Geissler595f6302022-01-24 19:11:47 +0000112 # install config
113 install -d ${D}${sysconfdir}
114 install -m 0644 ${S}/debian/mongod.conf ${D}${sysconfdir}
Andrew Geisslerd688a012020-09-18 13:36:00 -0500115
Andrew Geissler595f6302022-01-24 19:11:47 +0000116 # install systemd service
117 install -d ${D}${systemd_system_unitdir}
118 install -m 0644 ${S}/debian/mongod.service ${D}${systemd_system_unitdir}
Andrew Geisslerd688a012020-09-18 13:36:00 -0500119
Andrew Geissler595f6302022-01-24 19:11:47 +0000120 # install mongo data folder
121 install -m 755 -d ${D}${localstatedir}/lib/${BPN}
122 chown ${PN}:${PN} ${D}${localstatedir}/lib/${BPN}
Andrew Geisslerd688a012020-09-18 13:36:00 -0500123
Andrew Geissler595f6302022-01-24 19:11:47 +0000124 # Create /var/log/mongodb in runtime.
125 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
126 install -d ${D}${nonarch_libdir}/tmpfiles.d
127 echo "d ${localstatedir}/log/${BPN} 0755 ${BPN} ${BPN} -" > ${D}${nonarch_libdir}/tmpfiles.d/${BPN}.conf
128 fi
129 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'sysvinit', d)}" ]; then
130 install -d ${D}${sysconfdir}/default/volatiles
131 echo "d ${BPN} ${BPN} 0755 ${localstatedir}/log/${BPN} none" > ${D}${sysconfdir}/default/volatiles/99_${BPN}
132 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -0500133}
Andrew Geisslerd688a012020-09-18 13:36:00 -0500134
Patrick Williams213cb262021-08-07 19:21:33 -0500135CONFFILES:${PN} = "${sysconfdir}/mongod.conf"
Andrew Geisslerd688a012020-09-18 13:36:00 -0500136
Patrick Williams213cb262021-08-07 19:21:33 -0500137SYSTEMD_SERVICE:${PN} = "mongod.service"
Andrew Geissler595f6302022-01-24 19:11:47 +0000138
139FILES:${PN} += "${nonarch_libdir}/tmpfiles.d"