blob: 277fac9f7cf7d40f0ec0a8eb0e7a7d11a3347b40 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \
2safe memory reclamation mechanisms and non-blocking data structures \
3designed to aid in the design and implementation of high performance \
4concurrent systems."
5
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "BSD-2-Clause & Apache-2.0"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007HOMEPAGE = "http://concurrencykit.org"
8SECTION = "base"
9
Andrew Geissler517393d2023-01-13 08:55:19 -060010PV = "0.7.0+git${SRCPV}"
11SRCREV = "6e8e5bec2e2f8cef2072a68579cbb07ababf3331"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231"
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \
Andrew Geissler517393d2023-01-13 08:55:19 -060014 file://0001-configure-Fix-compoiler-detection-logic-for-cross-co.patch \
15 file://0001-build-Use-ilp32d-abi-on-riscv32-and-lp64d-on-rv64.patch"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016
17S = "${WORKDIR}/git"
18
Andrew Geissler517393d2023-01-13 08:55:19 -060019COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64|riscv32|riscv64).*-linux*"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
21inherit autotools-brokensep
22
Patrick Williams213cb262021-08-07 19:21:33 -050023PLAT:powerpc64 = "ppc64"
24PLAT:powerpc64le = "ppc64"
Andrew Geissler517393d2023-01-13 08:55:19 -060025PLAT:riscv32 = "riscv"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026PLAT ?= "${HOST_ARCH}"
27
28do_configure () {
29 export PLATFORM=${PLAT}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050030 ${S}/configure \
31 --prefix=${prefix} \
32 --includedir=${includedir} \
33 --libdir=${libdir}
34}
35
36do_compile () {
37 oe_runmake
38}
39
40do_install () {
41 oe_runmake 'DESTDIR=${D}' install
42}