blob: f2de593cf16f01801082e9bb7f7eb15b466132e8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A small tool to provide detailed information on the hardware \
2configuration of the machine. It can report exact memory configuration, \
3firmware version, mainboard configuration, CPU version and speed, cache \
4configuration, bus speed, etc. on DMI-capable or EFI systems."
5SUMMARY = "Hardware lister"
6HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
7SECTION = "console/tools"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "GPL-2.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
Andrew Geissler517393d2023-01-13 08:55:19 -060012COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64|riscv64).*-linux"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
Andrew Geissler517393d2023-01-13 08:55:19 -060014PV .= "+git${SRCPV}"
15SRCREV = "42fef565731411a784101de614a54bff79d1858e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016SRC_URI = " \
Andrew Geissler517393d2023-01-13 08:55:19 -060017 git://github.com/lyonel/lshw.git;protocol=https;branch=master \
18 file://0001-disable-docbook2man.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Andrew Geissler517393d2023-01-13 08:55:19 -060021S = "${WORKDIR}/git"
22
23inherit pkgconfig
24
25DEPENDS = "gettext-native"
26
27PACKAGECONFIG ??= "zlib"
28PACKAGECONFIG[sqlite] = "SQLITE=1,SQLITE=0,sqlite3"
29PACKAGECONFIG[zlib] = "ZLIB=1,ZLIB=0,zlib gzip-native"
30
31# use the PACKAGECONFIG configurations arguments
32EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
34do_compile() {
35 # build core only - don't ship gui
36 oe_runmake -C src core
37}
38
39do_install() {
40 oe_runmake install DESTDIR=${D}
41}
Brad Bishop19323692019-04-05 15:28:33 -040042
43BBCLASSEXTEND = "native"