blob: 019118f38b41209c6435feb201b83cf1823f8a19 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux Key Management Utilities"
2DESCRIPTION = "\
3 Utilities to control the kernel key management facility and to provide \
4 a mechanism by which the kernel call back to userspace to get a key \
5 instantiated. \
6 "
7HOMEPAGE = "http://people.redhat.com/dhowells/keyutils"
8SECTION = "base"
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -040011
12LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \
13 file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f"
14
Brad Bishop15ae2502019-06-18 21:44:24 -040015inherit siteinfo autotools-brokensep ptest
Brad Bishop19323692019-04-05 15:28:33 -040016
17SRC_URI = "http://people.redhat.com/dhowells/keyutils/${BP}.tar.bz2 \
18 file://keyutils-test-fix-output-format.patch \
19 file://keyutils-fix-error-report-by-adding-default-message.patch \
20 file://run-ptest \
Brad Bishop15ae2502019-06-18 21:44:24 -040021 file://fix_library_install_path.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060022 file://0001-tests-toolbox.inc.sh-update-regex-for-getting-endian.patch \
Brad Bishop19323692019-04-05 15:28:33 -040023 "
24
Brad Bishop0e2770c2020-01-21 07:31:46 -050025SRC_URI[md5sum] = "919af7f33576816b423d537f8a8692e8"
26SRC_URI[sha256sum] = "c8b15722ae51d95b9ad76cc6d49a4c2cc19b0c60f72f61fb9bf43eea7cbd64ce"
Brad Bishop19323692019-04-05 15:28:33 -040027
28EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \
29 NO_ARLIB=1 \
30 BINDIR=${base_bindir} \
31 SBINDIR=${base_sbindir} \
Brad Bishop15ae2502019-06-18 21:44:24 -040032 LIBDIR=${libdir} \
33 USRLIBDIR=${libdir} \
34 INCLUDEDIR=${includedir} \
Andrew Geisslereff27472021-10-29 15:35:00 -050035 ETCDIR=${sysconfdir} \
36 SHAREDIR=${datadir}/keyutils \
37 MANDIR=${datadir}/man \
Brad Bishop19323692019-04-05 15:28:33 -040038 BUILDFOR=${SITEINFO_BITS}-bit \
39 NO_GLIBC_KEYERR=1 \
40 "
41
42do_install () {
Brad Bishop15ae2502019-06-18 21:44:24 -040043 install -d ${D}/${libdir}/pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040044 oe_runmake DESTDIR=${D} install
45}
46
47do_install_ptest () {
48 cp -r ${S}/tests ${D}${PTEST_PATH}/
49 sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh
50}
51
Brad Bishop19323692019-04-05 15:28:33 -040052
Patrick Williams213cb262021-08-07 19:21:33 -050053RDEPENDS:${PN}-ptest += "lsb-release"
54RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils"
55RDEPENDS:${PN}-ptest:append:libc-musl = " musl-utils"
Brad Bishop15ae2502019-06-18 21:44:24 -040056
57BBCLASSEXTEND = "native nativesdk"