blob: 55233296995376b2f24039d9ac1976aa7da5b839 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
11 file://0001-docs-do-not-build-efisecdb-manpage.patch \
12 file://0001-src-Makefile-build-util.c-separately-for-makeguids.patch \
Andrew Geissler78b72792022-06-14 06:47:25 -050013 file://efisecdb-fix-build-with-musl-libc.patch \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050014 file://0001-Fix-invalid-free-in-main.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050015 file://0001-Fix-glibc-2.36-build-mount.h-conflicts.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060016 file://0001-Use-off_t-instead-of-off64_t.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000017 "
18SRCREV = "1753149d4176ebfb2b135ac0aaf79340bf0e7a93"
19
20S = "${WORKDIR}/git"
21
22inherit pkgconfig
23
24export CCLD_FOR_BUILD = "${BUILD_CCLD}"
25
26# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
27# enforce BFD.
28LDFLAGS += "-fuse-ld=bfd"
29
30do_compile() {
31 oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}"
32}
33
34do_install() {
35 oe_runmake install DESTDIR=${D}
36}
37
38BBCLASSEXTEND = "native"
39
40RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
41
42CLEANBROKEN = "1"