blob: 40df274c4c1587edb510ffe574d4f1053a164925 [file] [log] [blame]
Andrew Geisslerd1e89492021-02-12 15:35:20 -06001inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
William A. Kennington IIIac69b482021-06-02 12:28:27 -07004require core-image-minimal.bb
Brad Bishopc342db32019-05-15 21:57:59 -04005require conf/distro/include/ptest-packagelists.inc
6
William A. Kennington IIIac69b482021-06-02 12:28:27 -07007# Include only fast (< 30 sec) ptests
Brad Bishopc342db32019-05-15 21:57:59 -04008IMAGE_INSTALL += "${PTESTS_FAST}"
9
10DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
Andrew Geissler90fd73c2021-03-05 15:25:55 -060011HOMEPAGE = "https://www.yoctoproject.org/"
Brad Bishopc342db32019-05-15 21:57:59 -040012
13# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
14# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
15# box) and explicitly add just 1500MB.
16# strace-ptest in particular needs more than 500MB
17IMAGE_OVERHEAD_FACTOR = "1.0"
18IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
19
20# ptests need more memory than standard to avoid the OOM killer
21QB_MEM = "-m 1024"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23# Sadly at the moment the fast set of ptests is not robust enough and sporadically fails in a couple of places
24PTEST_EXPECT_FAILURE = "1"