blob: 00919a3d70ece6647619fe8b598a1667335fd4f6 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "rpcsvc protocol definitions from glibc"
5
6DESCRIPTION = "This package contains rpcsvc proto.x files from glibc, which are\
7missing in libtirpc. Additional it contains rpcgen, which is needed\
8to create header files and sources from protocol files.\
9This package is only needed, if glibc is installed without the\
10deprecated sunrpc functionality and libtirpc should replace it."
11
12HOMEPAGE = "https://github.com/thkukuk/rpcsvc-proto"
13LICENSE = "BSD-3-Clause"
14LIC_FILES_CHKSUM = "file://COPYING;md5=0daaf958d5531ab86169ec6e275e1517"
15SECTION = "libs"
16DEPENDS += "rpcsvc-proto-native"
17
Andrew Geissler595f6302022-01-24 19:11:47 +000018PV = "1.4.3"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Andrew Geissler595f6302022-01-24 19:11:47 +000020SRCREV = "71e0a12c04d130a78674ac6309eefffa6ecee612"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021
Andrew Geissler595f6302022-01-24 19:11:47 +000022SRC_URI = "git://github.com/thkukuk/${BPN};branch=master;protocol=https \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023 file://0001-Use-cross-compiled-rpcgen.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060024 file://0001-Use-AC_SYS_LARGEFILE-macro-to-control-largefile-supp.patch \
25 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026
27S = "${WORKDIR}/git"
28
Andrew Geisslerc182c622020-05-15 14:13:32 -050029inherit autotools gettext
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
Patrick Williams213cb262021-08-07 19:21:33 -050031EXTRA_OEMAKE:class-native = " -C rpcgen"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032
Patrick Williams213cb262021-08-07 19:21:33 -050033do_configure:prepend() {
Andrew Geisslerc182c622020-05-15 14:13:32 -050034 touch ${S}/ABOUT-NLS
35}
36
Patrick Williams213cb262021-08-07 19:21:33 -050037do_install:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 # They come from quota recipe
39 rm -rf ${D}${includedir}/rpcsvc/rquota.[hx]
40}
41
42BBCLASSEXTEND += "native nativesdk"