blob: 6aabf2e3b8b2a3789181095cb16152eda4bd2658 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
Patrick Williams2390b1b2022-11-03 13:47:49 -05008SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https;lfs=0 \
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009 file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060010 file://debugfix.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050011 file://0001-Qualify-move-as-std-move.patch;patchdir=third_party/spirv-cross \
Andrew Geissler517393d2023-01-13 08:55:19 -060012 file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch;patchdir=third_party/spdlog \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060013 "
14
15UPSTREAM_CHECK_COMMITS = "1"
Andrew Geissler517393d2023-01-13 08:55:19 -060016SRCREV = "8b945bebf8b2fd987dcf0eeca048068adf4ea44d"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060017
18UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
19S = "${WORKDIR}/git"
20
21REQUIRED_DISTRO_FEATURES = 'vulkan'
Andrew Geissler595f6302022-01-24 19:11:47 +000022COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64).*-linux"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060023
24inherit cmake features_check
25
Patrick Williams213cb262021-08-07 19:21:33 -050026FILES:${PN} += "${datadir}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060027
28#
29# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
30# used for logging with LOGE in the code. We need to make this match the value we use
31# in the debug source remapping from CFLAGS
32#
33EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
34# Binaries built with PCH enabled don't appear reproducible, differing results were seen
35# from some builds depending on the point the PCH was compiled. Disable it to be
36# deterministic
37EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
Patrick Williams213cb262021-08-07 19:21:33 -050038
39# This needs to be specified explicitly to avoid xcb/xlib dependencies
40EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"