blob: e4a17cbdd6f611b17917328c19d27fa9201b6a51 [file] [log] [blame]
Brad Bishop2f973922019-11-11 07:58:48 -05001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6DEPENDS = "c-ares cunit jansson libev libevent libxml2 openssl zlib"
7
8UPSTREAM_CHECK_URI = "https://github.com/nghttp2/nghttp2/releases"
9
10SRC_URI = "\
11 https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.xz \
12 file://0001-fetch-ocsp-response-use-python3.patch \
13"
Andrew Geissler5199d832021-09-24 16:47:35 -050014SRC_URI[sha256sum] = "abdc4addccadbc7d89abe27c4d6427d78e57d139f69c1f45749227393c68bf79"
Brad Bishop2f973922019-11-11 07:58:48 -050015
Andrew Geissler82c905d2020-04-13 13:39:40 -050016inherit cmake manpages python3native
Brad Bishop2f973922019-11-11 07:58:48 -050017PACKAGECONFIG[manpages] = ""
18
19# examples are never installed, and don't need to be built in the
20# first place
Andrew Geissler69721092021-07-23 12:57:00 -040021EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=ON -DENABLE_HPACK_TOOLS=OFF"
Brad Bishop2f973922019-11-11 07:58:48 -050022
23PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
26RDEPENDS:${PN}:class-native = ""
27RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
Brad Bishop2f973922019-11-11 07:58:48 -050028
Patrick Williams213cb262021-08-07 19:21:33 -050029ALLOW_EMPTY:${PN} = "1"
30FILES:${PN} = ""
31FILES:lib${PN} = "${libdir}/*${SOLIBS}"
32FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
33FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
34FILES:${PN}-server = "${bindir}/nghttpd"
Brad Bishop2f973922019-11-11 07:58:48 -050035
36BBCLASSEXTEND = "native"