blob: f86bf008f77dcc0b38113561aa7603aab46bf174 [file] [log] [blame]
Andrew Geissler97771a32021-03-05 15:23:11 -06001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
13
Andrew Geissler5199d832021-09-24 16:47:35 -050014SRC_URI[sha256sum] = "d440f2bc089ff628618c536904d5bc39d0b44f7afdda4c4c1ecd15fcf385bfba"
Andrew Geissler97771a32021-03-05 15:23:11 -060015
Patrick Williams213cb262021-08-07 19:21:33 -050016RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
Andrew Geissler97771a32021-03-05 15:23:11 -060017
18BBCLASSEXTEND = "native nativesdk"
Andrew Geissler32b11992021-03-31 13:37:05 -050019
20# Needs abseil-cpp which does not build for ppc64le/musl
Patrick Williams213cb262021-08-07 19:21:33 -050021COMPATIBLE_HOST:libc-musl:powerpc64le = "null"
Andrew Geissler32b11992021-03-31 13:37:05 -050022