blob: e1da1570ebbc5ea34520105297f3a9491bf6cf7e [file] [log] [blame]
Patrick Venturec57ab162018-09-22 18:56:00 -07001SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
2DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
14
15S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats"
Andrew Geisslerc4bf77a2020-12-21 18:03:18 +000017SRCREV = "6b48b92e08abba4e7b31d69c9a74b1d262718a84"
Patrick Venturec57ab162018-09-22 18:56:00 -070018
Patrick Williams12fc9392021-08-06 09:16:53 -050019FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
22FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venturec57ab162018-09-22 18:56:00 -070023
24HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"
William A. Kennington IIIccde0202021-06-04 17:45:28 -070025
26EXTRA_OECONF += "--disable-tests"