blob: d561fb26367fa373317339036bd65a70b4a9dd92 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# The WICVARS variable is used to define list of bitbake variables used in wic code
2# variables from this list is written to <image>.env file
3WICVARS ?= "\
Andrew Geissler5199d832021-09-24 16:47:35 -05004 APPEND \
5 ASSUME_PROVIDED \
6 BBLAYERS \
7 DEPLOY_DIR_IMAGE \
8 FAKEROOTCMD \
9 HOSTTOOLS_DIR \
10 IMAGE_BASENAME \
11 IMAGE_BOOT_FILES \
12 IMAGE_EFI_BOOT_FILES \
13 IMAGE_LINK_NAME \
14 IMAGE_ROOTFS \
15 IMGDEPLOYDIR \
16 INITRAMFS_FSTYPES \
17 INITRAMFS_IMAGE \
18 INITRAMFS_IMAGE_BUNDLE \
19 INITRAMFS_LINK_NAME \
20 INITRD \
21 INITRD_LIVE \
22 ISODIR \
23 KERNEL_IMAGETYPE \
24 MACHINE \
25 PSEUDO_IGNORE_PATHS \
26 RECIPE_SYSROOT_NATIVE \
27 ROOTFS_SIZE \
28 STAGING_DATADIR \
29 STAGING_DIR \
30 STAGING_LIBDIR \
31 TARGET_SYS \
32"
Brad Bishop96ff1982019-08-19 13:50:42 -040033
34inherit ${@bb.utils.contains('INITRAMFS_IMAGE_BUNDLE', '1', 'kernel-artifact-names', '', d)}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035
36WKS_FILE ??= "${IMAGE_BASENAME}.${MACHINE}.wks"
37WKS_FILES ?= "${WKS_FILE} ${IMAGE_BASENAME}.wks"
38WKS_SEARCH_PATH ?= "${THISDIR}:${@':'.join('%s/wic' % p for p in '${BBPATH}'.split(':'))}:${@':'.join('%s/scripts/lib/wic/canned-wks' % l for l in '${BBPATH}:${COREBASE}'.split(':'))}"
39WKS_FULL_PATH = "${@wks_search(d.getVar('WKS_FILES').split(), d.getVar('WKS_SEARCH_PATH')) or ''}"
40
41def wks_search(files, search_path):
42 for f in files:
43 if os.path.isabs(f):
44 if os.path.exists(f):
45 return f
46 else:
47 searched = bb.utils.which(search_path, f)
48 if searched:
49 return searched
50
51WIC_CREATE_EXTRA_ARGS ?= ""
52
Patrick Williams213cb262021-08-07 19:21:33 -050053IMAGE_CMD:wic () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050054 out="${IMGDEPLOYDIR}/${IMAGE_NAME}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050055 build_wic="${WORKDIR}/build-wic"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060056 tmp_wic="${WORKDIR}/tmp-wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050057 wks="${WKS_FULL_PATH}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060058 if [ -e "$tmp_wic" ]; then
59 # Ensure we don't have any junk leftover from a previously interrupted
60 # do_image_wic execution
61 rm -rf "$tmp_wic"
62 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050063 if [ -z "$wks" ]; then
64 bbfatal "No kickstart files from WKS_FILES were found: ${WKS_FILES}. Please set WKS_FILE or WKS_FILES appropriately."
65 fi
Andrew Geisslerd1e89492021-02-12 15:35:20 -060066 BUILDDIR="${TOPDIR}" PSEUDO_UNLOAD=1 wic create "$wks" --vars "${STAGING_DIR}/${MACHINE}/imgdata/" -e "${IMAGE_BASENAME}" -o "$build_wic/" -w "$tmp_wic" ${WIC_CREATE_EXTRA_ARGS}
Andrew Geissler82c905d2020-04-13 13:39:40 -050067 mv "$build_wic/$(basename "${wks%.wks}")"*.direct "$out${IMAGE_NAME_SUFFIX}.wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050068}
Patrick Williams213cb262021-08-07 19:21:33 -050069IMAGE_CMD:wic[vardepsexclude] = "WKS_FULL_PATH WKS_FILES TOPDIR"
Andrew Geissler82c905d2020-04-13 13:39:40 -050070do_image_wic[cleandirs] = "${WORKDIR}/build-wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050071
Andrew Geisslerf0343792020-11-18 10:42:21 -060072PSEUDO_IGNORE_PATHS .= ",${WORKDIR}/build-wic"
73
Brad Bishop6e60e8b2018-02-01 10:27:11 -050074# Rebuild when the wks file or vars in WICVARS change
75USING_WIC = "${@bb.utils.contains_any('IMAGE_FSTYPES', 'wic ' + ' '.join('wic.%s' % c for c in '${CONVERSIONTYPES}'.split()), '1', '', d)}"
76WKS_FILE_CHECKSUM = "${@'${WKS_FULL_PATH}:%s' % os.path.exists('${WKS_FULL_PATH}') if '${USING_WIC}' else ''}"
77do_image_wic[file-checksums] += "${WKS_FILE_CHECKSUM}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050078do_image_wic[depends] += "${@' '.join('%s-native:do_populate_sysroot' % r for r in ('parted', 'gptfdisk', 'dosfstools', 'mtools'))}"
79
80# We ensure all artfacts are deployed (e.g virtual/bootloader)
81do_image_wic[recrdeptask] += "do_deploy"
Andrew Geissler82c905d2020-04-13 13:39:40 -050082do_image_wic[deptask] += "do_image_complete"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050083
Brad Bishop08902b02019-08-20 09:16:51 -040084WKS_FILE_DEPENDS_DEFAULT = '${@bb.utils.contains_any("BUILD_ARCH", [ 'x86_64', 'i686' ], "syslinux-native", "",d)}'
85WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050086WKS_FILE_DEPENDS_BOOTLOADERS = ""
Patrick Williams213cb262021-08-07 19:21:33 -050087WKS_FILE_DEPENDS_BOOTLOADERS:x86 = "syslinux grub-efi systemd-boot"
88WKS_FILE_DEPENDS_BOOTLOADERS:x86-64 = "syslinux grub-efi systemd-boot"
89WKS_FILE_DEPENDS_BOOTLOADERS:x86-x32 = "syslinux grub-efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050090
91WKS_FILE_DEPENDS ??= "${WKS_FILE_DEPENDS_DEFAULT} ${WKS_FILE_DEPENDS_BOOTLOADERS}"
92
Brad Bishop6e60e8b2018-02-01 10:27:11 -050093DEPENDS += "${@ '${WKS_FILE_DEPENDS}' if d.getVar('USING_WIC') else '' }"
94
95python do_write_wks_template () {
96 """Write out expanded template contents to WKS_FULL_PATH."""
97 import re
98
99 template_body = d.getVar('_WKS_TEMPLATE')
100
101 # Remove any remnant variable references left behind by the expansion
102 # due to undefined variables
103 expand_var_regexp = re.compile(r"\${[^{}@\n\t :]+}")
104 while True:
105 new_body = re.sub(expand_var_regexp, '', template_body)
106 if new_body == template_body:
107 break
108 else:
109 template_body = new_body
110
111 wks_file = d.getVar('WKS_FULL_PATH')
112 with open(wks_file, 'w') as f:
113 f.write(template_body)
Brad Bishop08902b02019-08-20 09:16:51 -0400114 f.close()
115 # Copy the finalized wks file to the deploy directory for later use
116 depdir = d.getVar('IMGDEPLOYDIR')
117 basename = d.getVar('IMAGE_BASENAME')
118 bb.utils.copyfile(wks_file, "%s/%s" % (depdir, basename + '-' + os.path.basename(wks_file)))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500119}
120
Andrew Geissler82c905d2020-04-13 13:39:40 -0500121do_flush_pseudodb() {
122 ${FAKEROOTENV} ${FAKEROOTCMD} -S
123}
124
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500125python () {
126 if d.getVar('USING_WIC'):
127 wks_file_u = d.getVar('WKS_FULL_PATH', False)
128 wks_file = d.expand(wks_file_u)
129 base, ext = os.path.splitext(wks_file)
130 if ext == '.in' and os.path.exists(wks_file):
131 wks_out_file = os.path.join(d.getVar('WORKDIR'), os.path.basename(base))
132 d.setVar('WKS_FULL_PATH', wks_out_file)
133 d.setVar('WKS_TEMPLATE_PATH', wks_file_u)
134 d.setVar('WKS_FILE_CHECKSUM', '${WKS_TEMPLATE_PATH}:True')
135
136 # We need to re-parse each time the file changes, and bitbake
137 # needs to be told about that explicitly.
138 bb.parse.mark_dependency(d, wks_file)
139
140 try:
141 with open(wks_file, 'r') as f:
142 body = f.read()
143 except (IOError, OSError) as exc:
144 pass
145 else:
146 # Previously, I used expandWithRefs to get the dependency list
147 # and add it to WICVARS, but there's no point re-parsing the
148 # file in process_wks_template as well, so just put it in
149 # a variable and let the metadata deal with the deps.
150 d.setVar('_WKS_TEMPLATE', body)
Brad Bishop08902b02019-08-20 09:16:51 -0400151 bb.build.addtask('do_write_wks_template', 'do_image_wic', 'do_image', d)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400152 bb.build.addtask('do_image_wic', 'do_image_complete', None, d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500153}
154
155#
156# Write environment variables used by wic
157# to tmp/sysroots/<machine>/imgdata/<image>.env
158#
159python do_rootfs_wicenv () {
160 wicvars = d.getVar('WICVARS')
161 if not wicvars:
162 return
163
164 stdir = d.getVar('STAGING_DIR')
165 outdir = os.path.join(stdir, d.getVar('MACHINE'), 'imgdata')
166 bb.utils.mkdirhier(outdir)
167 basename = d.getVar('IMAGE_BASENAME')
168 with open(os.path.join(outdir, basename) + '.env', 'w') as envf:
169 for var in wicvars.split():
170 value = d.getVar(var)
171 if value:
172 envf.write('%s="%s"\n' % (var, value.strip()))
Brad Bishop08902b02019-08-20 09:16:51 -0400173 envf.close()
174 # Copy .env file to deploy directory for later use with stand alone wic
175 depdir = d.getVar('IMGDEPLOYDIR')
176 bb.utils.copyfile(os.path.join(outdir, basename) + '.env', os.path.join(depdir, basename) + '.env')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500177}
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500178addtask do_flush_pseudodb after do_rootfs before do_image do_image_qa
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500179addtask do_rootfs_wicenv after do_image before do_image_wic
180do_rootfs_wicenv[vardeps] += "${WICVARS}"
181do_rootfs_wicenv[prefuncs] = 'set_image_size'