blob: 53af7c616a9fed4c58403d344ec1e75d7e3213d4 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Systemd system configuration"
2DESCRIPTION = "Systemd may require slightly different configuration for \
3different machines. For example, qemu machines require a longer \
4DefaultTimeoutStartSec setting."
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
William A. Kennington IIIac69b482021-06-02 12:28:27 -07008PE = "1"
9
Andrew Geissler09209ee2020-12-13 08:44:15 -060010PACKAGECONFIG ??= "dhcp-ethernet"
11PACKAGECONFIG[dhcp-ethernet] = ""
12
Brad Bishopc342db32019-05-15 21:57:59 -040013SRC_URI = "\
14 file://journald.conf \
15 file://logind.conf \
16 file://system.conf \
17 file://system.conf-qemuall \
Brad Bishop15ae2502019-06-18 21:44:24 -040018 file://wired.network \
Brad Bishopc342db32019-05-15 21:57:59 -040019"
20
21do_install() {
22 install -D -m0644 ${WORKDIR}/journald.conf ${D}${systemd_unitdir}/journald.conf.d/00-${PN}.conf
23 install -D -m0644 ${WORKDIR}/logind.conf ${D}${systemd_unitdir}/logind.conf.d/00-${PN}.conf
Andrew Geissler5199d832021-09-24 16:47:35 -050024 install -D -m0644 ${WORKDIR}/system.conf ${D}${systemd_system_unitdir}.conf.d/00-${PN}.conf
Andrew Geissler09209ee2020-12-13 08:44:15 -060025
26 if ${@bb.utils.contains('PACKAGECONFIG', 'dhcp-ethernet', 'true', 'false', d)}; then
27 install -D -m0644 ${WORKDIR}/wired.network ${D}${systemd_unitdir}/network/80-wired.network
28 fi
Brad Bishopc342db32019-05-15 21:57:59 -040029}
30
31# Based on change from YP bug 8141, OE commit 5196d7bacaef1076c361adaa2867be31759c1b52
Patrick Williams213cb262021-08-07 19:21:33 -050032do_install:append:qemuall() {
Andrew Geissler5199d832021-09-24 16:47:35 -050033 install -D -m0644 ${WORKDIR}/system.conf-qemuall ${D}${systemd_system_unitdir}.conf.d/01-${PN}.conf
Brad Bishopc342db32019-05-15 21:57:59 -040034}
35
36PACKAGE_ARCH = "${MACHINE_ARCH}"
37
Patrick Williams213cb262021-08-07 19:21:33 -050038FILES:${PN} = "\
Brad Bishopc342db32019-05-15 21:57:59 -040039 ${systemd_unitdir}/journald.conf.d/ \
40 ${systemd_unitdir}/logind.conf.d/ \
Andrew Geissler5199d832021-09-24 16:47:35 -050041 ${systemd_system_unitdir}.conf.d/ \
Brad Bishop15ae2502019-06-18 21:44:24 -040042 ${systemd_unitdir}/network/ \
Brad Bishopc342db32019-05-15 21:57:59 -040043"