blob: 1cc201cf22ce4b26f1b3bb7239944286e6122d54 [file] [log] [blame]
Jeremy Kerr882199e2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
Ratan Guptadf7dfd42016-10-01 14:57:15 -05009inherit obmc-phosphor-discovery-service
Jeremy Kerr882199e2016-03-17 17:35:27 +080010
11TARGET_CFLAGS += "-fpic -O2"
12
Matthew Barth3e20a722016-09-26 16:26:27 -050013DEPENDS += "autoconf-archive-native"
14
Jeremy Kerr882199e2016-03-17 17:35:27 +080015SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishopf75c9602016-08-30 14:14:24 -040016SRC_URI += "file://${PN}.conf"
Jeremy Kerr2a9a9d72016-04-12 13:10:12 +080017
Andrew Geissler51abd0d2018-09-07 01:50:15 +000018SRCREV = "1864435759305800aeda41fc3e37baceb5762116"
Brad Bishop586e22612018-04-12 11:11:49 -040019PV = "1.0+git${SRCPV}"
Jeremy Kerr882199e2016-03-17 17:35:27 +080020
Ratan Guptadf7dfd42016-10-01 14:57:15 -050021REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200"
Vishwanatha Subbannae4bfd682016-10-01 11:34:42 -050022OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
23SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
Yi Lif1c10dd2016-10-21 12:08:47 +080024SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
Ratan Guptadf7dfd42016-10-01 14:57:15 -050025
Brad Bishopf75c9602016-08-30 14:14:24 -040026SYSTEMD_SERVICE_${PN} = " \
Vishwanatha Subbannae4bfd682016-10-01 11:34:42 -050027 ${PN}@.service \
28 ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
Brad Bishopf75c9602016-08-30 14:14:24 -040029 ${PN}-ssh.socket \
30 ${PN}-ssh@.service \
31 "
Jeremy Kerr882199e2016-03-17 17:35:27 +080032do_install_append() {
33 install -m 0755 -d ${D}${sysconfdir}
34 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr882199e2016-03-17 17:35:27 +080035}
36
37S = "${WORKDIR}/git"