blob: 37447038d0eca92bbac42d7e792f38108422334f [file] [log] [blame]
Matt Spinlerb45c1822018-03-26 16:23:38 -05001SUMMARY = "IBM DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML"
3PR = "r1"
Patrick Venture56e154e2018-10-17 15:10:55 -07004PV = "1.0+git${SRCPV}"
Matt Spinlerb45c1822018-03-26 16:23:38 -05005
6S = "${WORKDIR}/git"
7
8inherit autotools pkgconfig
9inherit obmc-phosphor-license
10inherit pythonnative
11inherit phosphor-dbus-yaml
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbus++-native"
15
16SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces"
Andrew Geisslerf617bc82018-10-04 21:30:14 +000017SRCREV = "c9ae6bf297b40391256c8f21a01d72e049036017"
Matt Spinlerb45c1822018-03-26 16:23:38 -050018
19DEPENDS_remove_class-native = "sdbus++-native"
20DEPENDS_remove_class-nativesdk = "sdbus++-native"
21
22PACKAGECONFIG ??= "libibm_dbus"
23PACKAGECONFIG[libibm_dbus] = " \
24 --enable-libibm_dbus, \
25 --disable-libibm_dbus, \
26 systemd sdbusplus, \
27 libsystemd sdbusplus \
28 "
29
30PACKAGECONFIG_remove_class-native = "libibm_dbus"
31PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus"
32
33BBCLASSEXTEND += "native nativesdk"