blob: 4fc437f5c241cd1d4d9059fbe307aa34ec895ba6 [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
Patrick Venture191bfab2018-10-17 07:42:11 -07007PV = "1.0+git${SRCPV}"
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05008LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
Brad Bishopd928e592020-11-15 13:49:49 -050011inherit meson pkgconfig systemd
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050012inherit obmc-phosphor-dbus-service
13
Adriana Kobylakb0e85222020-07-15 21:42:04 -050014# Static configuration. This is the default if no other layout is specified.
15inherit ${@bb.utils.contains_any('DISTRO_FEATURES', \
16 'openpower-ubi-fs phosphor-mmc', \
17 '', \
18 'openpower-software-manager-static', d)}
19
20# UBI layout
Lei YU3ba97552019-03-11 17:32:32 +080021inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-ubi-fs', \
22 'openpower-software-manager-ubi', \
Adriana Kobylakb0e85222020-07-15 21:42:04 -050023 '', d)}
24# eMMC layout
25inherit ${@bb.utils.contains('DISTRO_FEATURES', 'phosphor-mmc', \
26 'openpower-software-manager-mmc', \
27 '', d)}
28
29# Virtual PNOR
Adriana Kobylak8b805bd2019-10-25 15:24:38 -050030inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-virtual-pnor', \
31 'openpower-software-manager-virtual-pnor', \
32 '', d)}
Lei YU3ba97552019-03-11 17:32:32 +080033
Brad Bishopd928e592020-11-15 13:49:49 -050034PACKAGECONFIG[verify_pnor_signature] = "-Dverify-signature=enabled, -Dverify-signature=disabled"
35PACKAGECONFIG[ubifs_layout] = "-Ddevice-type=ubi,,,mtd-utils-ubifs"
36PACKAGECONFIG[mmc_layout] = "-Ddevice-type=mmc"
37PACKAGECONFIG[virtual_pnor] = "-Dvpnor=enabled, -Dvpnor=disabled"
Adriana Kobylakd7c95052018-05-07 13:28:09 -050038
Brad Bishopd928e592020-11-15 13:49:49 -050039EXTRA_OEMESON += " \
William A. Kennington IIIfe61aa32021-05-29 23:50:53 -070040 -Dtests=disabled \
Brad Bishopd928e592020-11-15 13:49:49 -050041 -Dmsl="v2.0.10 v2.2" \
Adriana Kobylak4315c912018-10-10 14:29:15 -050042 "
43
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050044DEPENDS += " \
Andrew Geissler334fec92020-12-01 18:51:54 +000045 cli11 \
Andrew Geisslerd564f2c2020-12-09 19:52:17 +000046 dbus \
Andrew Geisslera45b7532021-07-30 19:10:22 +000047 nlohmann-json \
Patrick Williams5ec7af72020-02-24 21:48:12 -060048 openssl \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050049 phosphor-dbus-interfaces \
50 phosphor-logging \
51 sdbusplus \
52 "
53
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000054RDEPENDS:${PN} += " \
Patrick Williams21d65692017-08-09 17:36:04 -050055 virtual-obmc-image-manager \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050056 "
57
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000058FILES:${PN} += "${datadir}/dbus-1/system.d/org.open_power.Software.Host.Updater.conf"
Andrew Geisslerd564f2c2020-12-09 19:52:17 +000059
Adriana Kobylak2e950822017-06-02 09:22:40 -050060S = "${WORKDIR}/git"
61
62SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
63
Andrew Geisslera45b7532021-07-30 19:10:22 +000064SRCREV = "5dc5d6cc6796ef038c59e41297349a982c8dd296"
Adriana Kobylak2e950822017-06-02 09:22:40 -050065
Patrick Williams57b76242021-08-11 15:27:06 -050066DBUS_SERVICE:${PN} += "org.open_power.Software.Host.Updater.service"
Adriana Kobylak2e950822017-06-02 09:22:40 -050067
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000068SYSTEMD_SERVICE:${PN} += " \
Adriana Kobylak32803f82018-10-10 09:47:17 -050069 op-pnor-msl.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050070 "