Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "XCB: The X protocol C binding library" |
| 2 | DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \ |
| 3 | for Xlib featuring a small footprint, latency hiding, direct access to \ |
| 4 | the protocol, improved threading support, and extensibility." |
| 5 | HOMEPAGE = "http://xcb.freedesktop.org" |
| 6 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB" |
| 7 | SECTION = "x11/libs" |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7" |
| 11 | |
| 12 | SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \ |
| 13 | file://xcbincludedir.patch \ |
| 14 | file://disable-check.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "f33cdfc67346f7217a9326c0d8679975" |
| 18 | SRC_URI[sha256sum] = "a89fb7af7a11f43d2ce84a844a4b38df688c092bf4b67683aef179cdf2a647c4" |
| 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |
| 21 | |
| 22 | DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp" |
| 23 | |
| 24 | PACKAGES_DYNAMIC = "^libxcb-.*" |
| 25 | |
| 26 | FILES_${PN} = "${libdir}/libxcb.so.*" |
| 27 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 28 | inherit autotools pkgconfig features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | |
| 30 | # The libxau and others requires x11 in DISTRO_FEATURES |
| 31 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | |
| 33 | export PYTHON = "python3" |
| 34 | |
| 35 | python populate_packages_prepend () { |
| 36 | do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True) |
| 37 | } |