Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Control process attributes through prctl" |
| 2 | DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \ |
| 3 | process' behaviour. Usage of the function is fairly messy though, due to \ |
| 4 | limitations in C and linux. This module provides a nice non-messy python(ic) \ |
| 5 | interface." |
| 6 | SECTION = "devel/python" |
| 7 | LICENSE = "GPLv3" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=1475481f9ec754d758859bd2c75f6f6f" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | B = "${S}" |
| 12 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 13 | SRCREV = "5e12e398eb5c4e30d7b29b02458c76d2cc780700" |
| 14 | PV = "1.8.1+git${SRCPV}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 16 | SRC_URI = "git://github.com/seveas/python-prctl;protocol=https;branch=main \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | file://0001-support-cross-complication.patch \ |
| 18 | " |
| 19 | inherit setuptools3 python3native |
| 20 | |
| 21 | DEPENDS += "libcap" |
| 22 | |