blob: aa80be95c194cb9f61a6574627263381e32e0740 [file] [log] [blame]
Brad Bishop83254dc2015-10-27 17:12:45 -04001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Matthew Barth11381c42016-10-05 16:20:54 -05008inherit autotools pkgconfig
Matthew Barth730ecb82016-11-16 10:17:02 -06009inherit obmc-phosphor-python-autotools
Brad Bishop83254dc2015-10-27 17:12:45 -040010inherit obmc-phosphor-dbus-service
11inherit obmc-phosphor-systemd
Brad Bishop83254dc2015-10-27 17:12:45 -040012
Brad Bishop5f077512016-08-07 23:18:32 -040013DEPENDS += "systemd"
Matthew Barth11381c42016-10-05 16:20:54 -050014DEPENDS += "autoconf-archive-native"
Rick Altherr68aa1402016-08-01 14:20:50 -070015
Brad Bishop59fc7e32016-11-02 15:21:22 -040016DBUS_SERVICE_${PN} += "xyz.openbmc_project.ObjectMapper.service"
Brad Bishop295bc642016-08-08 20:04:29 -040017SYSTEMD_SERVICE_${PN} = "mapper-wait@.service"
Matthew Barth11381c42016-10-05 16:20:54 -050018RDEPENDS_libmapper += "libsystemd"
Brad Bishop83254dc2015-10-27 17:12:45 -040019RDEPENDS_${PN} += " \
20 python-xml \
21 python-dbus \
22 python-pygobject \
23 "
Chris Austenb70cb7e2015-12-02 22:32:06 -060024SRC_URI += "git://github.com/openbmc/phosphor-objmgr"
Brad Bishop83254dc2015-10-27 17:12:45 -040025
Patrick Williams17183f22016-11-21 13:50:04 -060026SRCREV = "e3bd224d97b9db86a98a04d24c25de29f43165b5"
Brad Bishop83254dc2015-10-27 17:12:45 -040027
28S = "${WORKDIR}/git"
Brad Bishopea4022a2016-07-26 15:52:01 -040029
Brad Bishopea4022a2016-07-26 15:52:01 -040030python populate_packages_prepend () {
31 mapperlibdir = d.getVar("libdir", True)
32 do_split_packages(d, mapperlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Phosphor mapper %s library', extra_depends='', allow_links=True)
33}
34PACKAGES_DYNAMIC += "^libmapper.*"
35FILES_${PN}_remove = "${libdir}/lib*.so.* ${libdir}/*"