blob: 11da6b1be0fbc43412b53f854a2a91c22b5fbda4 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Brad Bishop316dfdd2018-06-25 12:45:53 -040017SRC_URI = "git://github.com/jackaudio/jack2.git"
18SRCREV = "c1647819eed6d11f94b21981d9c869629299f357"
19PV = "1.9.12"
Patrick Williamsddad1a12017-02-23 20:36:32 -060020S = "${WORKDIR}/git"
21
22inherit waf pkgconfig
23
24PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
26PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060027
28# portaudio is for windows builds only
29EXTRA_OECONF = "--portaudio=no"
30
31PACKAGES =+ "libjack jack-server jack-utils"
32
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
34
Patrick Williamsddad1a12017-02-23 20:36:32 -060035FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
36FILES_jack-server = "${bindir}/jackd"
37FILES_jack-utils = "${bindir}/*"
38FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "