blob: b280f583e26d90df06d803d1427df77911cca351 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Script-directed dynamic tracing and performance analysis tool for Linux"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "https://sourceware.org/systemtap/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
4require systemtap_git.inc
5
Brad Bishop316dfdd2018-06-25 12:45:53 -04006DEPENDS = "elfutils"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
8EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
9 --without-nss --without-avahi --without-dyninst \
10 --disable-server --disable-grapher --enable-prologues \
Brad Bishop37a0e4d2017-12-04 01:01:44 -050011 --with-python3 --without-python2-probes \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012 ac_cv_prog_have_javac=no \
13 ac_cv_prog_have_jar=no "
14
15STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
16
17EXTRA_OECONF += "${STAP_DOCS} "
18
Brad Bishop316dfdd2018-06-25 12:45:53 -040019PACKAGECONFIG ??= "translator sqlite monitor python3-probes"
20PACKAGECONFIG[translator] = "--enable-translator,--disable-translator,boost,python3-core bash perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050024PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025
Brad Bishop37a0e4d2017-12-04 01:01:44 -050026inherit autotools gettext pkgconfig distutils3-base
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027
Brad Bishop316dfdd2018-06-25 12:45:53 -040028do_install_append () {
29 if [ ! -f ${D}${bindir}/stap ]; then
30 # translator disabled case, need to leave only minimal runtime
31 rm -rf ${D}${datadir}/${PN}
32 rm ${D}${libexecdir}/${PN}/stap-env
33 fi
34}
35
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036BBCLASSEXTEND = "nativesdk"