blob: 33ed09ae8a0053c56e1af0e004ceb6c9bb4ef229 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
5LICENSE = "GPL-2 & PD"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \
8"
9DEPENDS = "attr zlib xz lzo lz4"
10
11PV = "4.3+gitr${SRCPV}"
12SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d"
13SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
14 http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \
Patrick Williamsd7e96312015-09-22 08:09:05 -050015 file://0001-mksquashfs.c-get-inline-functions-work-with-C99.patch;striplevel=2 \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016 file://fix-compat.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017"
18SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
19SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
20
21S = "${WORKDIR}/git/squashfs-tools"
22
23# EXTRA_OEMAKE is typically: -e MAKEFLAGS=
24# the -e causes problems as CFLAGS is modified in the Makefile, so
25# we redefine EXTRA_OEMAKE here
26EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1"
27
28do_compile() {
29 oe_runmake mksquashfs unsquashfs
30}
31do_install () {
32 install -d ${D}${sbindir}
33 install -m 0755 mksquashfs ${D}${sbindir}/
34 install -m 0755 unsquashfs ${D}${sbindir}/
35}
36
37ARM_INSTRUCTION_SET = "arm"
38
39BBCLASSEXTEND = "native nativesdk"