blob: a29c3d762e24d3d6b70f75b9df4223bfabfc9b69 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Linux Standard Base (LSB)"
6DESCRIPTION = "Packages required to satisfy the Linux Standard Base (LSB) specification"
7PR = "r10"
8LICENSE = "MIT"
9
10inherit packagegroup distro_features_check
11
12# The libxt, libxtst and others require x11 in DISTRO_FEATURES
13REQUIRED_DISTRO_FEATURES = "x11"
14
15#
16# We will skip parsing this packagegeoup for non-glibc systems
17#
18python __anonymous () {
19 if d.getVar('TCLIBC', True) != "glibc":
20 raise bb.parse.SkipPackage("incompatible with %s C library" %
21 d.getVar('TCLIBC', True))
22}
23
24PACKAGES = "\
25 packagegroup-core-lsb \
26 packagegroup-core-sys-extended \
27 packagegroup-core-db \
28 packagegroup-core-perl \
29 packagegroup-core-python \
30 packagegroup-core-tcl \
31 packagegroup-core-lsb-misc \
32 packagegroup-core-lsb-core \
33 packagegroup-core-lsb-perl \
34 packagegroup-core-lsb-python \
35 packagegroup-core-lsb-desktop \
36 packagegroup-core-lsb-runtime-add \
37 "
38
39
40RDEPENDS_packagegroup-core-lsb = "\
41 packagegroup-core-sys-extended \
42 packagegroup-core-db \
43 packagegroup-core-perl \
44 packagegroup-core-python \
45 packagegroup-core-tcl \
46 packagegroup-core-lsb-misc \
47 packagegroup-core-lsb-core \
48 packagegroup-core-lsb-perl \
49 packagegroup-core-lsb-python \
50 packagegroup-core-lsb-desktop \
51 packagegroup-core-lsb-runtime-add \
52 "
53
54
55RDEPENDS_packagegroup-core-sys-extended = "\
56 curl \
57 dhcp-client \
58 hdparm \
59 lighttpd \
60 libaio \
61 lrzsz \
62 lzo \
63 mc \
64 mc-fish \
65 mc-helpers \
66 mc-helpers-perl \
67 mc-helpers-python \
68 mdadm \
69 minicom \
70 neon \
71 parted \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072 quota \
73 screen \
74 setserial \
75 sysstat \
76 udev-extraconf \
77 unzip \
78 watchdog \
79 wget \
80 which \
81 xinetd \
82 zip \
83 "
84
85RDEPENDS_packagegroup-core-db = "\
86 db \
87 sqlite3 \
88 "
89
90RDEPENDS_packagegroup-core-perl = "\
91 gdbm \
92 perl \
93 zlib \
94 "
95
96
97RDEPENDS_packagegroup-core-python = "\
98 expat \
99 gdbm \
100 gmp \
101 ncurses \
102 openssl \
103 python \
104 readline \
105 zip \
106 "
107
108RDEPENDS_packagegroup-core-tcl = "\
109 tcl \
110 "
111
112# Miscellaneous packages required by LSB (or LSB tests)
113RDEPENDS_packagegroup-core-lsb-misc = "\
114 chkconfig \
115 gettext \
116 gettext-runtime \
117 groff \
118 lsbinitscripts \
119 lsbtest \
120 lsof \
121 strace \
122 libusb1 \
123 usbutils \
124 rpm \
125 "
126
127SUMMARY_packagegroup-core-lsb-core = "LSB Core"
128DESCRIPTION_packagegroup-core-lsb-core = "Packages required to support commands/libraries \
129 specified in the LSB Core specification"
130RDEPENDS_packagegroup-core-lsb-core = "\
131 at \
132 bash \
133 bc \
134 binutils \
135 binutils-symlinks \
136 coreutils \
137 cpio \
138 cronie \
139 cups \
140 diffutils \
141 ed \
142 glibc-utils \
143 elfutils \
144 file \
145 findutils \
146 fontconfig-utils \
147 foomatic-filters \
148 gawk \
149 ghostscript \
150 grep \
151 gzip \
152 localedef \
153 lsb \
154 m4 \
155 mailx \
156 make \
157 man \
158 man-pages \
159 mktemp \
160 msmtp \
161 patch \
162 pax \
163 procps \
164 psmisc \
165 sed \
166 shadow \
167 tar \
168 time \
169 util-linux \
170 xdg-utils \
171 \
172 glibc \
173 libgcc \
174 libpam \
175 libxml2 \
176 ncurses \
177 zlib \
178 nspr \
179 libpng12 \
180 nss \
181"
182
183SUMMARY_packagegroup-core-lsb-perl = "LSB Runtime Languages (Perl)"
184DESCRIPTION_packagegroup-core-lsb-perl = "Packages required to support libraries \
185 specified in the LSB Runtime languages specification (Perl parts)"
186RDEPENDS_packagegroup-core-lsb-perl = "\
187 perl \
188 perl-modules \
189 perl-misc \
190 perl-pod \
191 perl-dev \
192 perl-doc \
193"
194
195SUMMARY_packagegroup-core-lsb-python = "LSB Runtime Languages (Python)"
196DESCRIPTION_packagegroup-core-lsb-python = "Packages required to support libraries \
197 specified in the LSB Runtime languages specification (Python parts)"
198RDEPENDS_packagegroup-core-lsb-python = "\
199 python \
200 python-modules \
201 python-misc \
202"
203
204def get_libqt3(d):
205 if 'linuxstdbase' in d.getVar('DISTROOVERRIDES', False) or "":
206 if 'qt3' in d.getVar('BBFILE_COLLECTIONS', False) or "":
207 return 'libqt-mt3'
208
209 bb.warn('The meta-qt3 layer should be added, this layer provides Qt 3.x' \
210 'libraries. Its intended use is for passing LSB tests as Qt3 is' \
211 'a requirement for LSB.')
212 return ''
213
214QT4PKGS = " \
215 libqtcore4 \
216 libqtgui4 \
217 libqtsql4 \
218 libqtsvg4 \
219 libqtxml4 \
220 libqtnetwork4 \
221 qt4-plugin-sqldriver-sqlite \
222 ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "libqtopengl4", "", d)} \
223 "
224QT4PKGS_mips64 = ""
225QT4PKGS_mips64n32 = ""
226
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500227def get_libqt4(d):
228 if 'linuxstdbase' in d.getVar('DISTROOVERRIDES', False) or "":
229 if 'qt4' in d.getVar('BBFILE_COLLECTIONS', False) or "":
230 return d.getVar('QT4PKGS', False)
231
232 bb.warn('The meta-qt4 layer should be added, this layer provides Qt 4.x' \
233 'libraries. Its intended use is for passing LSB tests as Qt4 is' \
234 'a requirement for LSB.')
235 return ''
236
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500237SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
238DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
239 specified in the LSB Desktop specification"
240RDEPENDS_packagegroup-core-lsb-desktop = "\
241 libxt \
242 libxxf86vm \
243 libdrm \
244 libglu \
245 libxi \
246 libxtst \
247 libx11-locale \
248 xorg-minimal-fonts \
249 gdk-pixbuf-loader-ico \
250 gdk-pixbuf-loader-bmp \
251 gdk-pixbuf-loader-ani \
252 gdk-pixbuf-xlib \
253 liberation-fonts \
254 gtk+ \
255 atk \
256 libasound \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500257 ${@get_libqt4(d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258 ${@get_libqt3(d)} \
259"
260
261RDEPENDS_packagegroup-core-lsb-runtime-add = "\
262 ldd \
263 pam-plugin-wheel \
264 e2fsprogs-mke2fs \
265 mkfontdir \
266 liburi-perl \
267 libxml-parser-perl \
268 libxml-perl \
269 libxml-sax-perl \
270 glibc-localedatas \
271 glibc-gconvs \
272 glibc-charmaps \
273 glibc-binaries \
274 glibc-localedata-posix \
275 glibc-extra-nss \
276 glibc-pcprofile \
277 libclass-isa-perl \
278 libenv-perl \
279 libdumpvalue-perl \
280 libfile-checktree-perl \
281 libi18n-collate-perl \
282 libpod-plainer-perl \
283"