blob: 3ed90701204946ea0eedc3c788fd27dc4cf628b3 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
10LICENSE = "FreeType | GPLv2+"
11LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=4af6221506f202774ef74f64932878a1 \
12 file://docs/FTL.TXT;md5=d479e83797f699fe873b38dadd0fcd4c \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
16 file://use-right-libtool.patch"
17
18SRC_URI[md5sum] = "0037b25a8c090bc8a1218e867b32beb1"
19SRC_URI[sha256sum] = "371e707aa522acf5b15ce93f11183c725b8ed1ee8546d7b3af549863045863a2"
20
21inherit autotools pkgconfig binconfig-disabled multilib_header
22
23# Adapt autotools to work with the minimal autoconf usage in freetype
24AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
25CONFIGURE_SCRIPT = "${S}/configure"
26EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
27
28PACKAGECONFIG ??= "zlib"
29
30PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
31# harfbuzz results in a circular dependency so enabling is non-trivial
32PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
33PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
34PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
35
36EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
37
38TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
39
40do_install_append() {
41 oe_multilib_header freetype2/freetype/config/ftconfig.h
42}
43
44BINCONFIG = "${bindir}/freetype-config"
45
46BBCLASSEXTEND = "native"