blob: 15d925d29e49e536cbd6b5a61d05726c4063e9a4 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools lib_package
12
13DEPENDS = "liburcu util-linux"
14RDEPENDS_${PN}-bin = "python-core"
15
16# For backwards compatibility after rename
17RPROVIDES_${PN} = "lttng2-ust"
18RREPLACES_${PN} = "lttng2-ust"
19RCONFLICTS_${PN} = "lttng2-ust"
20
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050021SRCREV = "f89c1a3cf2b06a4970b9154c00ff6409870aefb5"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022PE = "2"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050023PV = "2.7.1+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050025SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.7 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050026 file://lttng-ust-doc-examples-disable.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050027 file://lttng-ust-add-support-for-aarch64_be.patch \
28 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029
30S = "${WORKDIR}/git"
31
32do_configure_prepend () {
33 ( cd ${S}; ${S}/bootstrap )
34}