blob: edca0bc46226b322aeba74ff6d579af2ce5940f8 [file] [log] [blame]
Andre McCurdy1ea3f662016-12-15 06:11:31 -08001DESCRIPTION = "Google's framework for writing C++ tests"
Brad Bishop26bdd442019-08-16 17:08:17 -04002HOMEPAGE = "https://github.com/google/googletest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08003SECTION = "libs"
4LICENSE = "BSD-3-Clause"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07005LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08006
Andrew Geissler615f2f12022-07-15 14:00:58 -05007PV = "1.12.1"
Brad Bishop996bc452019-12-02 13:05:15 -05008
Brad Bishop26bdd442019-08-16 17:08:17 -04009PROVIDES += "gmock gtest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080010
Brad Bishop316dfdd2018-06-25 12:45:53 -040011S = "${WORKDIR}/git"
Andrew Geissler615f2f12022-07-15 14:00:58 -050012SRCREV = "58d77fa8070e8cec2dc1ed015d66b454c8d78850"
13SRC_URI = "git://github.com/google/googletest.git;branch=v1.12.x;protocol=https"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080014
Andre McCurdy1ea3f662016-12-15 06:11:31 -080015inherit cmake
16
Patrick Williams213cb262021-08-07 19:21:33 -050017ALLOW_EMPTY:${PN} = "1"
18ALLOW_EMPTY:${PN}-dbg = "1"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080019
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN}-dev += "${PN}-staticdev"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080021
22BBCLASSEXTEND = "native nativesdk"
Brad Bishope42b3e32020-01-15 22:08:42 -050023
Patrick Williams213cb262021-08-07 19:21:33 -050024do_configure:prepend() {
Brad Bishope42b3e32020-01-15 22:08:42 -050025 # explicitly use python3
26 # the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
27 # but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
28 # there isn't python in HOSTTOOLS so "env python" fails
Patrick Williams58776372022-04-13 09:07:35 -050029 sed -i 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@g' ${S}/googlemock/test/*py ${S}/googletest/test/*py
Brad Bishope42b3e32020-01-15 22:08:42 -050030}