blob: d94fd3927312730fa8888e6ae9bccac927c9fd95 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
2DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
3By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
4polling, WebSockets, and other applications that require a long-lived connection to each user."
5HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
6LICENSE = "Apache-2.0"
Andrew Geissler4b7c1152020-11-30 19:55:29 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Andrew Geissler615f2f12022-07-15 14:00:58 -05009SRC_URI[sha256sum] = "9b630419bde84ec666bfd7ea0a4cb2a8a651c2d5cccdbdd1972a0c859dfc3c13"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
Andrew Geissler89770b02020-06-13 10:40:47 -050011inherit pypi setuptools3
12
13# Requires _compression which is currently located in misc
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \
Brad Bishop316dfdd2018-06-25 12:45:53 -040015 ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \
Andrew Geissler89770b02020-06-13 10:40:47 -050016 ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN}-test += "${PN} ${PYTHON_PN}-unittest"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019
20PACKAGES =+ "\
21 ${PN}-test \
22"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024FILES:${PN}-test = " \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025 ${libdir}/${PYTHON_DIR}/site-packages/*/test \
26 ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \
27"