blob: 2553974673410b0473187359115c0800aed250af [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Kernel Runtime Guard"
2DESCRIPTION="LKRG performs runtime integrity checking of the Linux \
3kernel and detection of security vulnerability exploits against the kernel."
4SECTION = "security"
5HOMEPAGE = "https://www.openwall.com/lkrg/"
Patrick Williamsde0582f2022-04-08 10:23:27 -05006LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007
8LIC_FILES_CHKSUM = "file://LICENSE;md5=5105ead24b08a32954f34cbaa7112432"
9
10DEPENDS = "virtual/kernel elfutils"
11
Patrick Williamsde0582f2022-04-08 10:23:27 -050012SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main \
Andrew Geissler615f2f12022-07-15 14:00:58 -050013 file://makefile_cleanup.patch \
14"
15
16SRCREV = "c578e9f786299b67ffd62057b4534b0bf4fb7ece"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017
Patrick Williamsde0582f2022-04-08 10:23:27 -050018S = "${WORKDIR}/git"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000019
20inherit module kernel-module-split
21
22MAKE_TARGETS = "modules"
23
24MODULE_NAME = "p_lkrg"
25
26module_do_install() {
27 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
28 install -m 0644 ${MODULE_NAME}.ko \
29 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
30}
31
32RPROVIDES:${PN} += "kernel-module-lkrg"
33
34COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"