blob: 6866a4d7380f0756c5e2f5c74934e1e0a9e52d50 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2007-2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Sato desktop"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06006DESCRIPTION = "Packagegroups provide a convenient mechanism of bundling a collection of packages."
7HOMEPAGE = "https://www.yoctoproject.org/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008PR = "r33"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
Brad Bishop6dbb3162019-11-25 09:41:34 -050012inherit packagegroup features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013REQUIRED_DISTRO_FEATURES = "x11"
14
15PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN} = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 ${PN}-base \
19 ${PN}-apps \
20 ${PN}-games \
21 "
22
23NETWORK_MANAGER ?= "connman-gnome"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
Patrick Williams213cb262021-08-07 19:21:33 -050025SUMMARY:${PN}-base = "Sato desktop - base packages"
26RDEPENDS:${PN}-base = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027 matchbox-desktop \
28 matchbox-session-sato \
29 matchbox-keyboard \
30 matchbox-keyboard-applet \
31 matchbox-keyboard-im \
32 matchbox-config-gtk \
33 xcursor-transparent-theme \
Andrew Geissler615f2f12022-07-15 14:00:58 -050034 sato-icon-theme \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035 settings-daemon \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036 shutdown-desktop \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037 ${NETWORK_MANAGER} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'udev-extraconf', d)} \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050039 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040 "
41
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042FILEMANAGER ?= "pcmanfm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043
44WEB ?= ""
45#WEB = "epiphany"
46
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047GSTEXAMPLES ?= "gst-examples"
Patrick Williams213cb262021-08-07 19:21:33 -050048GSTEXAMPLES:riscv64 = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049
Patrick Williams213cb262021-08-07 19:21:33 -050050SUMMARY:${PN}-apps = "Sato desktop - applications"
51RDEPENDS:${PN}-apps = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060052 l3afpad \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053 matchbox-terminal \
54 sato-screenshot \
55 ${FILEMANAGER} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056 ${GSTEXAMPLES} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057 ${WEB} \
58 "
59
Patrick Williams213cb262021-08-07 19:21:33 -050060SUMMARY:${PN}-games = "Sato desktop - games"
61RDEPENDS:${PN}-games = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060062 puzzles \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063 "