blob: 71d9518baf8f463c65d1d1221b8a427efbafb3dc [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
Andrew Geissler5f350902021-07-23 13:09:54 -040011LIC_FILES_CHKSUM = "file://LICENSE;md5=679b5c9bdc79a2b93ee574e193e7a7bc"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13SRC_URI = "https://github.com/libffi/libffi/releases/download/v${PV}/${BPN}-${PV}.tar.gz \
14 file://not-win32.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060015 file://0001-arm-sysv-reverted-clang-VFP-mitigation.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050016 "
Andrew Geissler5f350902021-07-23 13:09:54 -040017SRC_URI[sha256sum] = "540fb721619a6aba3bdeef7d940d8e9e0e6d2c193595bc243241b77ff9e93620"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
19UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
20
Andrew Geissler5f350902021-07-23 13:09:54 -040021EXTRA_OECONF += "--disable-builddir --disable-exec-static-tramp"
Andrew Geissler615f2f12022-07-15 14:00:58 -050022EXTRA_OECONF:class-native += "--with-gcc-arch=generic"
Patrick Williams213cb262021-08-07 19:21:33 -050023EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024inherit autotools texinfo multilib_header
25
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:append() {
Andrew Geissler635e0e42020-08-21 15:58:33 -050027 oe_multilib_header ffi.h ffitarget.h
Andrew Geissler82c905d2020-04-13 13:39:40 -050028}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030FILES:${PN}-dev += "${libdir}/libffi-${PV}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32# Doesn't compile in MIPS16e mode due to use of hand-written
33# assembly
34MIPS_INSTRUCTION_SET = "mips"
35
36BBCLASSEXTEND = "native nativesdk"