blob: 92d4fe0f4fc57fa8b0cd93117b2b72f0ee72de09 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection bash-completion
11
Brad Bishop26bdd442019-08-16 17:08:17 -040012DEPENDS = "glib-2.0 libgudev intltool-native libxslt-native"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
15 "
Brad Bishop36a3e3e2019-10-02 13:29:27 -040016
Brad Bishop63ae8782019-10-09 09:56:13 -040017SRC_URI[md5sum] = "7452a94f0d1ca361ae51ff1d287c53f5"
18SRC_URI[sha256sum] = "3c2ca73782215664141042422759899ca9846440fc26d6223c7cf7ea4dd3c996"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
20S = "${WORKDIR}/ModemManager-${PV}"
21
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG ??= "mbim qmi \
23 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024"
25
26PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
27PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
28# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
Brad Bishop19323692019-04-05 15:28:33 -040029PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
31PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
32
33EXTRA_OECONF = " \
34 --with-udev-base-dir=${nonarch_base_libdir}/udev \
35"
Brad Bishop26bdd442019-08-16 17:08:17 -040036EXTRA_OECONF_append_toolchain-clang = " --enable-more-warnings=no"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037
38FILES_${PN} += " \
39 ${datadir}/icons \
40 ${datadir}/polkit-1 \
41 ${datadir}/dbus-1 \
Brad Bishop36a3e3e2019-10-02 13:29:27 -040042 ${datadir}/ModemManager \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080043 ${libdir}/ModemManager \
44 ${systemd_unitdir}/system \
45"
46
47FILES_${PN}-dev += " \
48 ${libdir}/ModemManager/*.la \
49"
50
51FILES_${PN}-staticdev += " \
52 ${libdir}/ModemManager/*.a \
53"
54
55FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
56
57SYSTEMD_SERVICE_${PN} = "ModemManager.service"