blob: 1973c63f824f726f7c963cedd3b4583b0ed12e37 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
Brad Bishop19323692019-04-05 15:28:33 -040014GNOMEBASEBUILDCLASS = "meson"
15
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
17
18SRC_URI += "file://run-ptest \
Brad Bishop08902b02019-08-20 09:16:51 -040019 "
Brad Bishop19323692019-04-05 15:28:33 -040020
Brad Bishop08902b02019-08-20 09:16:51 -040021SRC_URI[archive.md5sum] = "7f91f1b5883ff848b445ab11ebabcf03"
22SRC_URI[archive.sha256sum] = "290bb100ca5c7025ec3f97332eaf783b76ba1f444110f06ac5ee3285e3e5aece"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
24DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
25
Brad Bishop08902b02019-08-20 09:16:51 -040026PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
27 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
Brad Bishop19323692019-04-05 15:28:33 -040028
Brad Bishop08902b02019-08-20 09:16:51 -040029PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
30PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33GIR_MESON_OPTION = 'introspection'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034
35LEAD_SONAME = "libpango-1.0*"
36LIBV = "1.8.0"
37
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
39FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
40
41RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
42
43RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
44 pango-module-basic-fc pango-module-arabic-lang"
45
Brad Bishop19323692019-04-05 15:28:33 -040046BBCLASSEXTEND = "native nativesdk"