blob: 416b031c5e2c7bab780db4d3a2782c32a1936874 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05004SUMMARY = "An aspect-oriented programming, monkey-patch and decorators library."
5DESCRIPTION = " It is useful when changing behavior in existing code is desired. \
6It includes tools for debugging and testing: simple mock/record and a complete capture/replay framework."
Andrew Geissler69721092021-07-23 12:57:00 -04007HOMEPAGE = "https://github.com/ionelmc/python-aspectlib"
8LICENSE = "BSD-2-Clause"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06009LIC_FILES_CHKSUM = "file://LICENSE;md5=80721ace117fd1f814049ecb81c6be76"
Andrew Geissler69721092021-07-23 12:57:00 -040010
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011SRC_URI[sha256sum] = "a4b461b9da0b531aebcb93efcde3de808a72c60226dd8d902c467d13faf7ce92"
Andrew Geissler69721092021-07-23 12:57:00 -040012
13inherit ptest pypi setuptools3
14
15SRC_URI += "file://run-ptest \
Andrew Geissler69721092021-07-23 12:57:00 -040016 "
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN}-ptest += "\
Andrew Geissler69721092021-07-23 12:57:00 -040024 python3-tornado \
25 python3-process-tests \
26"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN} += "python3-core python3-fields"
Andrew Geissler69721092021-07-23 12:57:00 -040029
30BBCLASSEXTEND = "native nativesdk"