blob: 39e689d2f6481260622528a3b74407b5a0823996 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=d148485768fe85b9f1072b186a7e9b4d"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060016 file://0001-20-resolv.conf-improve-the-sitation-of-working-with-.patch \
17 file://0001-privsep-Allow-getrandom-sysctl-for-newer-glibc.patch \
18 file://0002-privsep-Allow-newfstatat-syscall-as-well.patch \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060019 file://0001-privsep-linux-fix-SECCOMP_AUDIT_ARCH-missing-ppc64le.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050020 file://dhcpcd.service \
21 file://dhcpcd@.service \
22 "
23
24SRC_URI[sha256sum] = "819357634efed1ea5cf44ec01b24d3d3f8852fec8b4249925dcc5667c54e376c"
25
26inherit pkgconfig autotools-brokensep systemd useradd
27
28SYSTEMD_SERVICE:${PN} = "dhcpcd.service"
29
30PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
31
32PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
33PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
34# ntp conflicts with chrony
35PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
36PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
37PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
38
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000039# add option to override DBDIR location
40DBDIR ?= "${localstatedir}/lib/${BPN}"
41
Andrew Geisslereff27472021-10-29 15:35:00 -050042EXTRA_OECONF = "--enable-ipv4 \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000043 --dbdir=${DBDIR} \
Andrew Geisslereff27472021-10-29 15:35:00 -050044 --sbindir=${base_sbindir} \
45 --runstatedir=/run \
46 --enable-privsep \
47 --privsepuser=dhcpcd \
48 --with-hooks \
49 --with-eghooks \
50 "
51
52USERADD_PACKAGES = "${PN}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000053USERADD_PARAM:${PN} = "--system -d ${DBDIR} -M -s /bin/false -U dhcpcd"
Andrew Geisslereff27472021-10-29 15:35:00 -050054
55do_install:append () {
56 # install systemd unit files
57 install -d ${D}${systemd_system_unitdir}
58 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_system_unitdir}
59
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000060 chmod 700 ${D}${DBDIR}
61 chown dhcpcd:dhcpcd ${D}${DBDIR}
Andrew Geisslereff27472021-10-29 15:35:00 -050062}
63
64FILES:${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"