blob: f8a2482a8480d1901a9c7d6cdd78e9098b2ce01e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
12 file://CVE-2022-48281.patch"
Andrew Geissler517393d2023-01-13 08:55:19 -060013
14SRC_URI[sha256sum] = "c7a1d9296649233979fa3eacffef3fa024d73d05d589cb622727b5b08c423464"
15
16# exclude betas
17UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
18
19# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
20# and 4.3.0 doesn't have the issue
21CVE_CHECK_IGNORE += "CVE-2015-7313"
22# These issues only affect libtiff post-4.3.0 but before 4.4.0,
23# caused by 3079627e and fixed by b4e79bfa.
24CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
25# Issue is in jbig which we don't enable
26CVE_CHECK_IGNORE += "CVE-2022-1210"
27
28inherit autotools multilib_header
29
30CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
31
32PACKAGECONFIG ?= "cxx jpeg zlib lzma \
33 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
34
35PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
36PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
37PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
38PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
39PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
40PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
Patrick Williams864cc432023-02-09 14:54:44 -060041PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
42PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
Andrew Geissler517393d2023-01-13 08:55:19 -060043
44# Convert single-strip uncompressed images to multiple strips of specified
45# size (default: 8192) to reduce memory usage
46PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
47
48# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
49PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
50
51# Control picking up YCbCr subsample info. Disable to support files lacking
52# the tag
53PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
54
55# Support a mechanism allowing reading large strips (usually one strip files)
56# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
57PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
58
59PACKAGES =+ "tiffxx tiff-utils"
60FILES:tiffxx = "${libdir}/libtiffxx.so.*"
61FILES:tiff-utils = "${bindir}/*"
62
63do_install:append() {
64 oe_multilib_header tiffconf.h
65}
66
67BBCLASSEXTEND = "native nativesdk"