blob: 67c926b2c99f9de4f9b9fbd9f8e1fa825b0f7aea [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Yet Another Flash File System"
2DESCRIPTION = "Tools for managing 'yaffs2' file systems."
3
4SECTION = "base"
5HOMEPAGE = "http://www.yaffs.net"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=12;endline=14;md5=5f5464f9b3e981ca574e65b00e438561"
9
10PV = "0.0+git${SRCPV}"
11
12DEPENDS = "mtd-utils"
13
14# Source is the HEAD of master branch at the time of writing this recipe
Patrick Williamsddad1a12017-02-23 20:36:32 -060015SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \
16 file://makefile-add-ldflags.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017 file://0001-define-loff_t-if-not-already-defined.patch \
18 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060019
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020SRCREV = "bc76682d93955cfb33051beb503ad9f8a5450578"
21S = "${WORKDIR}/git"
22
23CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES"
24EXTRA_OEMAKE = "-e MAKEFLAGS="
25
26do_compile() {
27 cd utils && oe_runmake
28}
29
30INSTALL_FILES = "mkyaffsimage \
31 mkyaffs2image \
32 "
33do_install() {
34 install -d ${D}${sbindir}/
35 for i in ${INSTALL_FILES}; do
36 install -m 0755 utils/$i ${D}${sbindir}/
37 done
38}
39
40BBCLASSEXTEND = "native"