Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Custom Matchbox session files" |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 2 | DESCRIPTION = "Very simple session manager for matchbox tools" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | HOMEPAGE = "http://www.matchbox-project.org/" |
| 4 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://matchbox-session;endline=20;md5=180f1c169a15d059a56c30094f6fb5ea" |
| 8 | |
| 9 | SECTION = "x11" |
| 10 | RCONFLICTS_${PN} = "matchbox-common" |
| 11 | |
| 12 | SRC_URI = "file://matchbox-session" |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | PR = "r4" |
| 16 | |
| 17 | inherit update-alternatives |
| 18 | |
| 19 | ALTERNATIVE_${PN} = "x-session-manager" |
| 20 | ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/matchbox-session" |
| 21 | ALTERNATIVE_PRIORITY = "100" |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}/${bindir} |
| 25 | install -m 0755 ${S}/matchbox-session ${D}/${bindir} |
| 26 | } |