Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3" |
| 2 | DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \ |
| 3 | mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \ |
| 4 | and also can write the decoded audio to WAV." |
| 5 | HOMEPAGE = "http://mpg123.de/" |
| 6 | BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/" |
| 7 | SECTION = "multimedia" |
| 8 | |
| 9 | LICENSE = "LGPLv2.1" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=e7b9c15fcfb986abb4cc5e8400a24169" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 12 | SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "081991540df7a666b29049ad870f293cfa28863b36488ab4d58ceaa7b5846454" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 15 | UPSTREAM_CHECK_REGEX = "mpg123-(?P<pver>\d+(\.\d+)+)\.tar" |
| 16 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | inherit autotools pkgconfig |
| 18 | |
| 19 | # The options should be mutually exclusive for configuration script. |
| 20 | # If both alsa and pulseaudio are specified (as in the default distro features) |
| 21 | # pulseaudio takes precedence. |
| 22 | PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}" |
| 23 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}" |
| 24 | |
| 25 | PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib" |
| 26 | PACKAGECONFIG[esd] = ",,esound" |
| 27 | PACKAGECONFIG[jack] = ",,jack" |
| 28 | PACKAGECONFIG[openal] = ",,openal-soft" |
| 29 | PACKAGECONFIG[portaudio] = ",,portaudio-v19" |
| 30 | PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 31 | PACKAGECONFIG[sdl] = ",,libsdl2" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | |
| 33 | # Following are possible sound output modules: |
| 34 | # alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi |
| 35 | AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}" |
| 36 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}" |
| 37 | |
| 38 | EXTRA_OECONF = " \ |
| 39 | --enable-shared \ |
| 40 | --with-audio='${AUDIOMODS}' \ |
| 41 | ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \ |
| 42 | ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 43 | ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-cpu=generic_nofpu', '', d)} \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 44 | " |
| 45 | # Fails to build with thumb-1 (qemuarm) |
| 46 | #| {standard input}: Assembler messages: |
| 47 | #| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4' |
| 48 | #| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24' |
| 49 | #... |
| 50 | #| make[3]: *** [equalizer.lo] Error 1 |
| 51 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 52 | ARM_INSTRUCTION_SET_armv5 = "arm" |