blob: 3e85cbb8efe47f1f0d4d189f1286d5837a3b9bf0 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY:${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION:${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY:python3-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION:python3-rpm = "The python3-rpm package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22
23# libraries are also LGPL - how to express this?
24LICENSE = "GPL-2.0-only"
25LIC_FILES_CHKSUM = "file://COPYING;md5=c4eec0c20c6034b9407a09945b48a43f"
26
Andrew Geissler87f5cff2022-09-30 13:13:31 -050027SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.18.x;protocol=https \
Patrick Williams92b42cb2022-09-03 06:53:57 -050028 file://0001-Do-not-add-an-unsatisfiable-dependency-when-building.patch \
29 file://0001-Do-not-read-config-files-from-HOME.patch \
30 file://0001-When-cross-installing-execute-package-scriptlets-wit.patch \
31 file://0001-Do-not-reset-the-PATH-environment-variable-before-ru.patch \
32 file://0002-Add-support-for-prefixing-etc-from-RPM_ETCCONFIGDIR-.patch \
33 file://0001-Do-not-hardcode-lib-rpm-as-the-installation-path-for.patch \
34 file://0001-Add-a-color-setting-for-mips64_n32-binaries.patch \
35 file://0001-perl-disable-auto-reqs.patch \
36 file://0016-rpmscript.c-change-logging-level-around-scriptlets-t.patch \
37 file://0001-lib-transaction.c-fix-file-conflicts-for-MIPS64-N32.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050038 file://0001-build-pack.c-do-not-insert-payloadflags-into-.rpm-me.patch \
39 file://0001-configure.ac-add-linux-gnux32-variant-to-triplet-han.patch \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050040 file://0001-python-Use-Py_hash_t-instead-of-long-in-hdr_hash.patch \
Patrick Williamse760df82023-05-26 11:10:49 -050041 file://fix-declaration.patch \
Andrew Geissler8f840682023-07-21 09:09:43 -050042 file://ea3187cfcf9cac87e5bc5e7db79b0338da9e355e.patch \
Patrick Williams705982a2024-01-12 09:51:57 -060043 file://0001-Duplicate-filename-before-passing-it-to-basename.patch \
44 file://0001-Fix-missing-basename-include-on-macOS.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050045 "
46
47PE = "1"
Patrick Williamse760df82023-05-26 11:10:49 -050048SRCREV = "4588bc3f994338502d2770ad24cbfcdaa6c335ec"
Patrick Williams92b42cb2022-09-03 06:53:57 -050049
50S = "${WORKDIR}/git"
51
52DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3"
53DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
54
55inherit autotools gettext pkgconfig python3native
56export PYTHON_ABI
57
58AUTOTOOLS_AUXDIR = "${S}/build-aux"
59
60# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
61EXTRA_AUTORECONF:append = " --exclude=gnu-configize"
62
63# Vendor is detected differently on x86 and aarch64 hosts and can feed into target packages
64EXTRA_OECONF:append = " --enable-python --with-crypto=libgcrypt --with-vendor=pc"
65EXTRA_OECONF:append:libc-musl = " --disable-nls --disable-openmp"
66
67# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs
68# --localstatedir prevents rpm from writing its database to native sysroot when building images
69# Forcibly disable plugins for native/nativesdk, as the inhibit and prioreset
70# plugins both behave badly inside builds.
71EXTRA_OECONF:append:class-native = " --sysconfdir=/etc --localstatedir=/var --disable-plugins"
72EXTRA_OECONF:append:class-nativesdk = " --sysconfdir=/etc --disable-plugins"
73
74BBCLASSEXTEND = "native nativesdk"
75
76PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'inhibit', '', d)} sqlite zstd"
77# The inhibit plugin serves no purpose outside of the target
78PACKAGECONFIG:remove:class-native = "inhibit"
79PACKAGECONFIG:remove:class-nativesdk = "inhibit"
80
81PACKAGECONFIG[imaevm] = "--with-imaevm,,ima-evm-utils"
82PACKAGECONFIG[inhibit] = "--enable-inhibit-plugin,--disable-inhibit-plugin,dbus"
83PACKAGECONFIG[rpm2archive] = "--with-archive,--without-archive,libarchive"
84PACKAGECONFIG[sqlite] = "--enable-sqlite=yes,--enable-sqlite=no,sqlite3"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050085PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
Patrick Williams92b42cb2022-09-03 06:53:57 -050086PACKAGECONFIG[ndb] = "--enable-ndb,--disable-ndb"
87PACKAGECONFIG[bdb-ro] = "--enable-bdb-ro,--disable-bdb-ro"
88PACKAGECONFIG[zstd] = "--enable-zstd=yes,--enable-zstd=no,zstd"
89
90ASNEEDED = ""
91
92# Direct rpm-native to read configuration from our sysroot, not the one it was compiled in
93# libmagic also has sysroot path contamination, so override it
94
95WRAPPER_TOOLS = " \
96 ${bindir}/rpm \
97 ${bindir}/rpm2archive \
98 ${bindir}/rpm2cpio \
99 ${bindir}/rpmbuild \
100 ${bindir}/rpmdb \
101 ${bindir}/rpmgraph \
102 ${bindir}/rpmkeys \
103 ${bindir}/rpmsign \
104 ${bindir}/rpmspec \
105 ${libdir}/rpm/rpmdeps \
106"
107
108do_configure:prepend() {
109 mkdir -p ${S}/build-aux
110}
111
112do_install:append:class-native() {
113 for tool in ${WRAPPER_TOOLS}; do
114 test -x ${D}$tool && create_wrapper ${D}$tool \
115 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
116 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} \
117 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
118 RPM_NO_CHROOT_FOR_SCRIPTS=1
119 done
120}
121
122do_install:append:class-nativesdk() {
Patrick Williams92b42cb2022-09-03 06:53:57 -0500123 rm -rf ${D}/var
124
Andrew Geissler517393d2023-01-13 08:55:19 -0600125 mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
126 cat <<- EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/rpm.sh
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500127 export RPM_CONFIGDIR="${libdir}/rpm"
128 export RPM_ETCCONFIGDIR="${SDKPATHNATIVE}"
Andrew Geissler517393d2023-01-13 08:55:19 -0600129 export RPM_NO_CHROOT_FOR_SCRIPTS=1
130 EOF
Patrick Williams92b42cb2022-09-03 06:53:57 -0500131}
132
133# Rpm's make install creates var/tmp which clashes with base-files packaging
134do_install:append:class-target() {
135 rm -rf ${D}/var
136}
137do_install:append:class-nativesdk() {
138 rm -rf ${D}${SDKPATHNATIVE}/var
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500139 # Ensure find-debuginfo is located correctly inside SDK
Patrick Williams520786c2023-06-25 16:20:36 -0500140 mkdir -p ${D}${libdir}/rpm
141 echo "%__find_debuginfo ${SDKPATHNATIVE}/usr/bin/find-debuginfo" >> ${D}${libdir}/rpm/macros
Patrick Williams92b42cb2022-09-03 06:53:57 -0500142}
143
144do_install:append () {
145 sed -i -e 's:${HOSTTOOLS_DIR}/::g' \
146 ${D}/${libdir}/rpm/macros
147
148}
149
150FILES:${PN} += "${libdir}/rpm-plugins/*.so \
151 "
152FILES:${PN}:append:class-nativesdk = " ${SDKPATHNATIVE}/environment-setup.d/rpm.sh"
153
154FILES:${PN}-dev += "${libdir}/rpm-plugins/*.la \
155 "
156PACKAGE_BEFORE_PN += "${PN}-build ${PN}-sign ${PN}-archive"
157
158RRECOMMENDS:${PN} += "rpm-sign rpm-archive"
159
160FILES:${PN}-build = "\
161 ${bindir}/rpmbuild \
162 ${bindir}/gendiff \
163 ${bindir}/rpmspec \
164 ${libdir}/librpmbuild.so.* \
165 ${libdir}/rpm/brp-* \
166 ${libdir}/rpm/check-* \
Patrick Williams92b42cb2022-09-03 06:53:57 -0500167 ${libdir}/rpm/sepdebugcrcfix \
Patrick Williams92b42cb2022-09-03 06:53:57 -0500168 ${libdir}/rpm/find-lang.sh \
169 ${libdir}/rpm/*provides* \
170 ${libdir}/rpm/*requires* \
171 ${libdir}/rpm/*deps* \
172 ${libdir}/rpm/*.prov \
173 ${libdir}/rpm/*.req \
174 ${libdir}/rpm/config.* \
175 ${libdir}/rpm/mkinstalldirs \
176 ${libdir}/rpm/macros.p* \
177 ${libdir}/rpm/fileattrs/* \
178"
179
180FILES:${PN}-sign = "\
181 ${bindir}/rpmsign \
182 ${libdir}/librpmsign.so.* \
183"
184
185FILES:${PN}-archive = "\
186 ${bindir}/rpm2archive \
187"
188
189PACKAGES += "python3-rpm"
190PROVIDES += "python3-rpm"
Patrick Williamse760df82023-05-26 11:10:49 -0500191FILES:python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/* ${PYTHON_SITEPACKAGES_DIR}/rpm-*.egg-info"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500192
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500193RDEPENDS:${PN}-build = "bash perl python3-core debugedit"
Patrick Williams92b42cb2022-09-03 06:53:57 -0500194
195PACKAGE_PREPROCESS_FUNCS += "rpm_package_preprocess"
196
197# Do not specify a sysroot when compiling on a target.
198rpm_package_preprocess () {
199 sed -i -e 's:--sysroot[^ ]*::g' \
200 ${PKGD}/${libdir}/rpm/macros
201}
202
203SSTATE_HASHEQUIV_FILEMAP = " \
204 populate_sysroot:*/rpm/macros:${TMPDIR} \
205 populate_sysroot:*/rpm/macros:${COREBASE} \
206 "