blob: a9e31b50ea5fb5b4c118e1dc43ec5294fc6c1975 [file] [log] [blame]
Brad Bishop96ff1982019-08-19 13:50:42 -04001inherit goarch
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002
Brad Bishop316dfdd2018-06-25 12:45:53 -04003GO_PARALLEL_BUILD ?= "${@oe.utils.parallel_make_argument(d, '-p %d')}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004
5GOROOT_class-native = "${STAGING_LIBDIR_NATIVE}/go"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006GOROOT_class-nativesdk = "${STAGING_DIR_TARGET}${libdir}/go"
7GOROOT = "${STAGING_LIBDIR}/go"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008export GOROOT
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009export GOROOT_FINAL = "${libdir}/go"
Brad Bishopc8f47122019-06-24 09:36:18 -040010export GOCACHE = "${B}/.cache"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
Brad Bishopd89cb5f2019-04-10 09:02:41 -040012export GOARCH = "${TARGET_GOARCH}"
13export GOOS = "${TARGET_GOOS}"
14export GOHOSTARCH="${BUILD_GOARCH}"
15export GOHOSTOS="${BUILD_GOOS}"
16
17GOARM[export] = "0"
18GOARM_arm_class-target = "${TARGET_GOARM}"
19GOARM_arm_class-target[export] = "1"
20
21GO386[export] = "0"
22GO386_x86_class-target = "${TARGET_GO386}"
23GO386_x86_class-target[export] = "1"
Brad Bishopd89cb5f2019-04-10 09:02:41 -040024
25GOMIPS[export] = "0"
26GOMIPS_mips_class-target = "${TARGET_GOMIPS}"
27GOMIPS_mips_class-target[export] = "1"
28
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029DEPENDS_GOLANG_class-target = "virtual/${TUNE_PKGARCH}-go virtual/${TARGET_PREFIX}go-runtime"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030DEPENDS_GOLANG_class-native = "go-native"
31DEPENDS_GOLANG_class-nativesdk = "virtual/${TARGET_PREFIX}go-crosssdk virtual/${TARGET_PREFIX}go-runtime"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033DEPENDS_append = " ${DEPENDS_GOLANG}"
34
35GO_LINKSHARED ?= "${@'-linkshared' if d.getVar('GO_DYNLINK') else ''}"
36GO_RPATH_LINK = "${@'-Wl,-rpath-link=${STAGING_DIR_TARGET}${libdir}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
37GO_RPATH = "${@'-r ${libdir}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
38GO_RPATH_class-native = "${@'-r ${STAGING_LIBDIR_NATIVE}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
39GO_RPATH_LINK_class-native = "${@'-Wl,-rpath-link=${STAGING_LIBDIR_NATIVE}/go/pkg/${TARGET_GOTUPLE}_dynlink' if d.getVar('GO_DYNLINK') else ''}"
40GO_EXTLDFLAGS ?= "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS} ${GO_RPATH_LINK} ${LDFLAGS}"
41GO_LINKMODE ?= ""
42GO_LINKMODE_class-nativesdk = "--linkmode=external"
43GO_LDFLAGS ?= '-ldflags="${GO_RPATH} ${GO_LINKMODE} -extldflags '${GO_EXTLDFLAGS}'"'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050044export GOBUILDFLAGS ?= "-v ${GO_LDFLAGS} -trimpath"
Brad Bishop316dfdd2018-06-25 12:45:53 -040045export GOPATH_OMIT_IN_ACTIONID ?= "1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050046export GOPTESTBUILDFLAGS ?= "${GOBUILDFLAGS} -c"
Brad Bishop316dfdd2018-06-25 12:45:53 -040047export GOPTESTFLAGS ?= ""
Brad Bishopd7bf8c12018-02-25 22:55:05 -050048GOBUILDFLAGS_prepend_task-compile = "${GO_PARALLEL_BUILD} "
49
50export GO = "${HOST_PREFIX}go"
51GOTOOLDIR = "${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go/pkg/tool/${BUILD_GOTUPLE}"
52GOTOOLDIR_class-native = "${STAGING_LIBDIR_NATIVE}/go/pkg/tool/${BUILD_GOTUPLE}"
53export GOTOOLDIR
54
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055export CGO_ENABLED ?= "1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050056export CGO_ENABLED_riscv64 = "0"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050057export CGO_CFLAGS ?= "${CFLAGS}"
58export CGO_CPPFLAGS ?= "${CPPFLAGS}"
59export CGO_CXXFLAGS ?= "${CXXFLAGS}"
60export CGO_LDFLAGS ?= "${LDFLAGS}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050061
62GO_INSTALL ?= "${GO_IMPORT}/..."
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063GO_INSTALL_FILTEROUT ?= "${GO_IMPORT}/vendor/"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064
Brad Bishopd7bf8c12018-02-25 22:55:05 -050065B = "${WORKDIR}/build"
66export GOPATH = "${B}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040067export GOTMPDIR ?= "${WORKDIR}/go-tmp"
68GOTMPDIR[vardepvalue] = ""
Brad Bishopd7bf8c12018-02-25 22:55:05 -050069
70python go_do_unpack() {
71 src_uri = (d.getVar('SRC_URI') or "").split()
72 if len(src_uri) == 0:
73 return
74
Brad Bishop08902b02019-08-20 09:16:51 -040075 fetcher = bb.fetch2.Fetch(src_uri, d)
76 for url in fetcher.urls:
77 if fetcher.ud[url].type == 'git':
78 if fetcher.ud[url].parm.get('destsuffix') is None:
79 s_dirname = os.path.basename(d.getVar('S'))
80 fetcher.ud[url].parm['destsuffix'] = os.path.join(s_dirname, 'src', d.getVar('GO_IMPORT')) + '/'
81 fetcher.unpack(d.getVar('WORKDIR'))
Brad Bishopd7bf8c12018-02-25 22:55:05 -050082}
83
84go_list_packages() {
85 ${GO} list -f '{{.ImportPath}}' ${GOBUILDFLAGS} ${GO_INSTALL} | \
86 egrep -v '${GO_INSTALL_FILTEROUT}'
87}
88
89go_list_package_tests() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040090 ${GO} list -f '{{.ImportPath}} {{.TestGoFiles}}' ${GOBUILDFLAGS} ${GO_INSTALL} | \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050091 grep -v '\[\]$' | \
92 egrep -v '${GO_INSTALL_FILTEROUT}' | \
93 awk '{ print $1 }'
94}
95
96go_do_configure() {
97 ln -snf ${S}/src ${B}/
98}
Brad Bishop316dfdd2018-06-25 12:45:53 -040099do_configure[dirs] =+ "${GOTMPDIR}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500100
101go_do_compile() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400102 export TMPDIR="${GOTMPDIR}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500103 if [ -n "${GO_INSTALL}" ]; then
Brad Bishop316dfdd2018-06-25 12:45:53 -0400104 if [ -n "${GO_LINKSHARED}" ]; then
105 ${GO} install ${GOBUILDFLAGS} `go_list_packages`
106 rm -rf ${B}/bin
107 fi
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500108 ${GO} install ${GO_LINKSHARED} ${GOBUILDFLAGS} `go_list_packages`
109 fi
110}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400111do_compile[dirs] =+ "${GOTMPDIR}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500112do_compile[cleandirs] = "${B}/bin ${B}/pkg"
113
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500114go_do_install() {
115 install -d ${D}${libdir}/go/src/${GO_IMPORT}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400116 tar -C ${S}/src/${GO_IMPORT} -cf - --exclude-vcs --exclude '*.test' --exclude 'testdata' . | \
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500117 tar -C ${D}${libdir}/go/src/${GO_IMPORT} --no-same-owner -xf -
Brad Bishopc342db32019-05-15 21:57:59 -0400118 tar -C ${B} -cf - --exclude-vcs pkg | tar -C ${D}${libdir}/go --no-same-owner -xf -
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500119
120 if [ -n "`ls ${B}/${GO_BUILD_BINDIR}/`" ]; then
121 install -d ${D}${bindir}
122 install -m 0755 ${B}/${GO_BUILD_BINDIR}/* ${D}${bindir}/
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500123 fi
124}
125
Brad Bishop316dfdd2018-06-25 12:45:53 -0400126go_stage_testdata() {
127 oldwd="$PWD"
128 cd ${S}/src
129 find ${GO_IMPORT} -depth -type d -name testdata | while read d; do
130 if echo "$d" | grep -q '/vendor/'; then
131 continue
132 fi
133 parent=`dirname $d`
134 install -d ${D}${PTEST_PATH}/$parent
135 cp --preserve=mode,timestamps -R $d ${D}${PTEST_PATH}/$parent/
136 done
137 cd "$oldwd"
138}
139
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500140EXPORT_FUNCTIONS do_unpack do_configure do_compile do_install
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500141
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500142FILES_${PN}-dev = "${libdir}/go/src"
143FILES_${PN}-staticdev = "${libdir}/go/pkg"
144
145INSANE_SKIP_${PN} += "ldflags"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800146
147# Add -buildmode=pie to GOBUILDFLAGS to satisfy "textrel" QA checking, but mips
148# doesn't support -buildmode=pie, so skip the QA checking for mips and its
149# variants.
150python() {
Andrew Geissler82c905d2020-04-13 13:39:40 -0500151 if 'mips' in d.getVar('TARGET_ARCH') or 'riscv' in d.getVar('TARGET_ARCH'):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800152 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
153 else:
154 d.appendVar('GOBUILDFLAGS', ' -buildmode=pie')
155}