blob: cca60ddae21fd0bd263535ca15fd34a1e95dcbff [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
16 file://dhcpcd.service \
17 file://dhcpcd@.service \
18 "
19
Andrew Geissler706d5aa2021-02-12 15:55:30 -060020SRC_URI[sha256sum] = "6d49af5e766a2515e6366e4f669663df04ecdf90a1a60ddb1d7a2feb4b5d2566"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050021
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050022inherit pkgconfig autotools-brokensep systemd useradd
Andrew Geisslerc9f78652020-09-18 14:11:35 -050023
24SYSTEMD_SERVICE_${PN} = "dhcpcd.service"
25
26PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
27
28PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
Andrew Geissler4c19ea12020-10-27 13:52:24 -050030# ntp conflicts with chrony
31PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
32PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
33PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050034
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050035EXTRA_OECONF = "--enable-ipv4 \
36 --dbdir=${localstatedir}/lib/${BPN} \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060037 --sbindir=${base_sbindir} \
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050038 --runstatedir=/run \
Andrew Geissler4c19ea12020-10-27 13:52:24 -050039 --enable-privsep \
40 --privsepuser=dhcpcd \
41 --with-hooks \
42 --with-eghooks \
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050043 "
44
45USERADD_PACKAGES = "${PN}"
46USERADD_PARAM_${PN} = "--system -d ${localstatedir}/lib/${BPN} -M -s /bin/false -U dhcpcd"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050047
48do_install_append () {
49 # install systemd unit files
50 install -d ${D}${systemd_unitdir}/system
51 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_unitdir}/system
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050052
53 chmod 700 ${D}${localstatedir}/lib/${BPN}
54 chown dhcpcd:dhcpcd ${D}${localstatedir}/lib/${BPN}
Andrew Geisslerc9f78652020-09-18 14:11:35 -050055}
56
57FILES_${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"