blob: afcb4d508e3561988695e0a7620f1ea57980a265 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A sophisticated network protocol analyzer"
2HOMEPAGE = "http://www.tcpdump.org/"
Brad Bishop19323692019-04-05 15:28:33 -04003SECTION = "net"
Brad Bishop2d39a062019-10-28 08:33:36 -04004LICENSE = "BSD-3-Clause"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=1d4b0366557951c84a94fabe3529f867"
Brad Bishop19323692019-04-05 15:28:33 -04006
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS = "libpcap"
8
Brad Bishop63ae8782019-10-09 09:56:13 -04009RDEPENDS_${PN}-ptest += " make perl \
10 perl-module-file-basename \
11 perl-module-posix \
12 perl-module-carp"
13
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014SRC_URI = " \
15 http://www.tcpdump.org/release/${BP}.tar.gz \
16 file://unnecessary-to-check-libpcap.patch \
Brad Bishop19323692019-04-05 15:28:33 -040017 file://avoid-absolute-path-when-searching-for-libdlpi.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 file://add-ptest.patch \
19 file://run-ptest \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060020 file://0001-PPP-When-un-escaping-don-t-allocate-a-too-large-buff.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021"
22
Brad Bishop63ae8782019-10-09 09:56:13 -040023SRC_URI[md5sum] = "a4ead41d371f91aa0a2287f589958bae"
24SRC_URI[sha256sum] = "2cd47cb3d460b6ff75f4a9940f594317ad456cfbf2bd2c8e5151e16559db6410"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
Andrew Geissler72956ed2021-01-08 16:11:14 -060026UPSTREAM_CHECK_REGEX = "tcpdump-(?P<pver>\d+(\.(?!99)\d+)+)\.tar"
27
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028inherit autotools-brokensep ptest
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029
Brad Bishop19323692019-04-05 15:28:33 -040030PACKAGECONFIG ?= "openssl"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031
Brad Bishop19323692019-04-05 15:28:33 -040032PACKAGECONFIG[libcap-ng] = "--with-cap-ng,--without-cap-ng,libcap-ng"
Andrew Geissler7f40b712020-05-15 14:09:53 -050033PACKAGECONFIG[openssl] = "--with-crypto,--without-crypto,openssl"
Brad Bishop19323692019-04-05 15:28:33 -040034PACKAGECONFIG[smi] = "--with-smi,--without-smi,libsmi"
Brad Bishop63ae8782019-10-09 09:56:13 -040035# Note: CVE-2018-10103 (SMB - partially fixed, but SMB printing disabled)
36PACKAGECONFIG[smb] = "--enable-smb,--disable-smb"
Brad Bishop19323692019-04-05 15:28:33 -040037
38EXTRA_AUTORECONF += "-I m4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039
40do_configure_prepend() {
41 mkdir -p ${S}/m4
42 if [ -f aclocal.m4 ]; then
43 mv aclocal.m4 ${S}/m4
44 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045}
46
47do_install_append() {
Brad Bishop19323692019-04-05 15:28:33 -040048 # make install installs an unneeded extra copy of the tcpdump binary
Brad Bishop6e60e8b2018-02-01 10:27:11 -050049 rm -f ${D}${sbindir}/tcpdump.${PV}
50}
51
52do_compile_ptest() {
53 oe_runmake buildtest-TESTS
54}